Rendering not using AMD card

When I render with my MacBook pro, it uses a lot of processor memory and almost none of the GPU.

Can I fix this?

It is set to using the hardware acceleration (AMD radeon R9) in system preferences.

I have tried to render it in Rhino 6 for mac, but there it crashes as soon as I start the rendering.

Any help would be greatly appreciated.

The renderer in Rhino 5 doesn’t use the GPU at all.

GPU accelleration is available in the WIP (v6 to be) through the Raytraced mode (and the Rhino Render Next plug-in for it)

Thank you,

I have tried the WIP renderer and it crashes as soon as I try to render something. I have tried both with setting the device to AMD with openGL and also only cpu.

I have also tried rendering several different files with no luck, just the wheel of death and then crash.

I do not know what the Rhino render next plug in is, can I download it?

Thomas

Does this mean that Rhino crashes the moment you set the display mode to Raytraced?

No it crashes when I try to render the scene. The Display mode works but I can not see the shadows in it, it also uses a lot of GPU and there is no way of telling if it has finished rendering.

I do not use rendering that much, since I normally do sculptures, but now I am using an image as a reference for a painting. The raytracing mode is so much better and I am a little bummed that I can not/do not know how to use it.

If you have any tips they are welcome.

Ah, rendering with the Render button. That is separate from the Raytraced mode.

If you are not seeing any shadows in it you may have either too much light, or for instance no groundplane - maybe you could share a model you are working with? If you rather do that confidentially you can use rhino3d.com/upload/?to=nathan@mcneel.com . I’ll be notified when the upload is completed (the e-mail adress in the recipient field is mine). I can then probably give better instructions on how to get better results out.

Installing the Rhino Render Next plug-in isn’t straightforward, so lets ignore that for now. You should be able to get started with the Raytraced mode together with the ViewCaptureToClipboard and ViewCaptureToFile commands.

By default the Raytraced mode will do 1000 samples, so it is done when it has reach that count - the HUD will say “Completed” then as well instead of “Rendering…”. If you want to have more indication of how much has been rendered of what target count then in RhinoWIP > Preferences... > Advanced search for RhinoCycles.MaxPasses and set it to true:

.

Under RhinoWIP > Preferences... > Cycles you can set the amount of samples to do for a complete rendering in the viewport

1 Like

@broome, I was going through my inbox, and notice the upload notification from your model - it got snowed under by the huge amount of internal development post that I missed it. Sorry about that.

The reason you are not seeing any shadows (especially on the wall surface) is because the wall has a picture material that has self-illumination enabled. This makes it work like a light really, so any shadows falling on it will not be perceptible.

Further, your spot light has shadow intensity set to 0%, so it won’t cast shadows down on the shelf.