Rendering issue with Flamingo nXt 5 in Rhino 5

I’m trying to render a simple model of a bed that’s made of several block instances. Using the built-in Rhino render, the result is fine. When I render the scene using Flamingo nXt 5 (16334.11523, built on 2018/03/06), a wide dark band appears on the side of the pillow.

I made the pillow by following this tutorial:

I think this is related to a block instance being rotated or mirrored because one of the short bed posts exhibited something similar while it was mirrored in an earlier version of this model. (The black bands appeared on the sphere part of the bed post.)

When I removed the mirroring (just inserted the block instance as is), the rendering came out fine. I cannot reproduce this anymore with this version of the model.

Did I do something wrong or is this a Flamingo bug?

Bed_RenderingIssue.7z (1.8 MB)

Does my question need more detail to receive a reply from support? I’d be glad to add more information, although I’d imagine the model should have everything (unless I missed something when putting the zip file together).

I created a few renderings to experiment with what may introduce the rendering problem.

Inserted the block as separate objects - rendering is as expected:


Inserted block as a block instance (linked, active layers) - rendering as expected:


Inserted block as a block instance and rotated it by 90 degrees - the black rendering artifact is back:


Note that I rotated the block itself by 90 degrees (using the gumball, around the Z axis). I tried adding the block instance both using active or reference layers; same result.

What can I do to avoid this? So far pretty much any block instance I tried (regardless of complexity) fails to render correctly when rotated. I’m not sure if this is the only scenario when this happens with Flamingo nXt.

Is it known when this problem will be fixed? I did another test (files available if needed) and it pretty conclusively shows that this is a bug in either Rhino or Flamingo nxt.

It’d be nice to know if there’s a workaround for this because I haven’t been able to render a useful image out of Flamingo nxt so far. Is it possible to install Flamingo 2 on Rhino 5?

I am also experiencing this issue (I notice this thread is over a year old and still causing problems).
Essentially it seems that Rhino doesn’t recognise when a block is rotated and gives the block its own lighting that is independent of the global environment.
Did you ever find a fix to this issue?

I’m sorry, I haven’t seen your post until now. I got a reply from John Morse (McNeel support) a while back, saying that there’s a Flamingo nXt setting MinInstanceReferenceCount that needs to be set to 1 (the default is 3).

I don’t understand what this setting controls (and I definitely don’t get why the default is 3 when the rendering comes out correct with 1 but that’s what it is).

The setting is under Tools -> Options -> Advanced; type in the name of the setting to filter the list down to it and then set it to 1.

Hope this helps.

@A111 – FYi