Rendering inserted blocks - [SOLVED]


I could not find an appropriate answer on this.

I divided a large model of a building into different models due to size. It makes working in Rhino so much faster.

I then combine all models into one for final renders.

I have a problem when rendering. It seems like to inserted blocks only render black and white.

I have attached Flamingo materials inside the individual models. So when I insert them they come in with their materials.

Flamingo doesn’t render these blocks. Almost as if they are locked (Greyed out).

Is there a setting to overcome this. Also I don’t really want to explode the inserted blocks for obvious reasons.

Any help will be appreciated.


Big_G -

Is this in Rhino 5? Are you using Flamingo NXT 5?

Can you send me two of the block files? I will take a look.


Thanks for your help.

2 x pictures ans 2 x models attached.


JTA Block 4.3dm (3.1 MB)
JTA Block 3.3dm (4.1 MB)


I forgot to mention I am using: Rhino Ver 5 SR 12 64-bit


I had to export my model to Sketchup and Render with Twilight Render and Visualizer to get this project out.

Not a good outcome. Does anybody on this forum know of a work around or what the problem is.

The model has lost many of its material assignments on the layers. So the render is not using real Flamingo material definitions. I am not sure why this is. I am looking into it.

Also, does this rendering also have outside walls?

Scott, the combined model consists of 9 blocks which form a complete building including outside walls. I only uploaded two of the blocks.

I seemed to have solved my problem with the grey un-rendered blocks in my model.

I assigned all my materials by layer , but some of my parts (Blocks) in my model had materials by object

After I selected all my parts (Control A) and changed the properties under materials by layer my model rendered perfectly.

Just be careful with the layer management to place your part in the correct layers for render purposes.

Hope this info is helpful to someone.