Rendering Emitters Inside Blocks in Maxwell


#1

Hi All,

First off, I wouldn’t be posting here if I were able to post in the Maxwell Render forums, but for reasons unknown, I am unable to do so. I’m working on a model in R5 64-bit and using Maxwell Render 2.7.27. I have my various lights arranged in blocks (makes sense, one would think) so I can easily apply materials to the respective layers and have them update across all instances if I need to change something. Unfortunately, when I render, I find that the Emitter material is only applying to some of the bulbs and not to others, and I don’t understand why. Meshing the blocks and their objects doesn’t fix the problem. Exploding the blocks makes the objects disappear from the rendering altogether (even stranger). Suffice it to say that I’m currently out of ideas and unsure what to do. I’ve tried applying the material to the bulb layer, to the objects directly…nothing seems to change for the better.

Thanks for any help you can give!


(Brian James) #2

Hi Rob,

Can you select two of the lights… one that works and one that doesn’t and Export as 3dm for me? My first guess is that there are duplicates where it’s not working.


#3

Passing materials through blocks is an on and off problem for the Maxwell plugin. Last time this came up for me was materials in imported blocks. This should have been fixed in 2.7.22.

To be able to post in the Maxwell Forums, you need to apply for VIP Status. This Information is a bit hard to find. Every registered user may read, VIPs need to verify as a customer and are allowed to post.

http://www.maxwellrender.com/forum/viewtopic.php?f=3&t=8941


#4

I might have been able to fix it by toggling the Hidden checkbox under Maxwell Object Properties. Also, there seemed to be a general trend that it was happening only to mirrored blocks, and correcting that gave me some sporadic success. If the problem persists further, I’ll upload a 3dm with what you ask for. Thanks!


#5

By toggling do you mean “set and then reset it” or was the hidden option enabled? Did you at some point enable it or did it get activated on it’s own?


#6

Nope, the hidden box had not been checked. I figured I would try checking it and then unchecking it to see if that made a difference, and on occasion it did. I’ve uploaded a 3dm of the lights for you and Brian. One block instance is working and another block instance isn’t even showing up in the Fire preview now, never mind the emitter. Thanks!

Lights.3dm (674.1 KB)