Rendering curves inside transparent object

I have noticed that you can’t render curves when they are within objects with a transparent material assigned.
It wasn’t possible in Rhino 5 either but it was up to Rhino 4.
The same also applies to annotations.
The workaround I have been using is to apply curve piping to the curves I need to render but it would be nice to have this option back to reduce file size and computational times - it can make it quite laggy when there are thousands of curves in the scene.

Hello - I see that - I’ll add it to the pile of things to look at but my guess is you’ll need to keep going with curve piping for now. Of course V4’s renderer did not take IOR into account - my guess of the moment is that is one reason this is not supported in V5 + - adding curves is a post effect, not part of the ray trace process and it would still, as things are now, ignore IOR, whereas pipes do not, they get raytraced.