"Render Pen" mode switching to grey scale

one of my old stand-bys since the introduction of the tech-pipeline has been a custom display Pen mode with materials and shadows.

in the beta, it looks great, as long as you don’t move the camera! See video.

@jeff any idea on this one?

Hey @ATH! Haven’t chatted with you in a while…

I believe this very bug just fell onto my list today…


I’ll let you know when it’s fixed…it’s slated to be worked on today.


well, fear not I am still a super fan! As you can see before it turns grey it is a really great look and I forever impressed by the improvements.

Hey @ATH,

Just letting you know I just committed a fix for this tonight… If you’re on daily builds, it should be in one of tomorrow’s builds (Wednesday).

Let me know if it fixes your issue as well.


the problem remains… any thing I can do to help?


Note: Yesterday’s Beta release will NOT have this fix in it…my change went in after the Beta snapshot… So the only way you will be able to test this now is if you’re on the daily builds refresh.

Can you gab a screenshot of Rhino’s “About” screen and paste it here.

Also, export your display mode and post the .ini file here so I can test it out…


Don’t actually know how to get those builds!

rendered pen.ini (11.3 KB)


Ya, that’s not the right version… Sorry for the confusion… You’ll have to wait until next Tuesday… Or…

Run the command “TestMaterialCache” to turn off material caching… Note: This is not remembered across Rhino sessions so you will have to run it every time you start Rhino… Also note: Turning off material caching may impact your overall performance… But for now, it should get you the correct results.

Let me know.