Render Output Control?

In perspective view, render display mode, I get my scene just how I like. Then when I click render and the render window opens and starts to do its things, the final output has the underside of my ceiling raft dark ? Is there a way to match what’s in the viewport to what the output gives when clicking into the Render Window ? I’m confused :thinking::crazy_face::thinking:

1 Like

anyone ? @DavidEranen @dan @theoutside

@BrianJ Can you tell what is going on here?

Rhino 6 for Mac will not calculate indirect illumination so light will not bounce back up to the ceiling raft just as it doesn’t lighten the underside of the chair. If you are on Rhino 6 for Mac, you can use the Raytraced display mode which will calculate indirect illumination. If you use that approach, make sure to use a material for the ground plane in the Rendering panel settings or make a large plane to act as the floor to bounce the light.

Hi @BrianJ, what I don’t get is why the viewport doesn’t match with the output. If render doesn’t calculate indirect lighting, the viewport shouldn’t be showing something else, this is plain wrong and confusing…

1 Like

Hi Brian, just testing a small scene, switch to raytraced as suggested, now seeing something between a shaded/wireframe display mode ?? I’ve never had this before, screenshot attached and test file too.
Mesh Screen 1 .3dm (5.1 MB)

Check your Display panel, I think you have surface edges enabled in Raytraced mode. You will probably also want to reset your Rendering panel to use the default settings.

Because Raytraced mode uses a different technology (Cycles) versus the older Rhino Render. In Rhino 7 Rhino Render will (and already is in the WIP) be the same as Raytraced. For Rhino 6 this wasn’t possible yet so we shipped Raytraced mode as another rendering option.

something funky going on I think, screenshots of view in rendered mode & RT, switch to raytraced seems like a grayscale mode ? never had this happen before :thinking:

You are sure you don’t have tweaks (accidental or not) to your Raytraced mode? Like for instance only white color for all objects.

Thanks, I was aware of this, but I think it leads to a lot of confusion. We shouldn’t call two different things by the same name, if you are in renderer viewport and you hit render you should get the same image, just the quality should change.

Hi Nathan, yep, not sure what I did, but restored RT display mode default, looks right :+1: , cheers
@BrianJ I’ll have a look at Render in the V7 WIP Mac

@BrianJ ok, just testing another scene in V7 WIP, set my perspective view in rendered mode, then clicked Render, window opens, half my viewport is missing and I have a black background ?

That is probably due to usage of Transparent.

Note that Rhino Render in v7 is the same as Raytraced :slight_smile:

the main problem is that 3/4 of my view isn’t even in the render window, surely if I set my scene in perspective view, click render, it shouldn’t chop most of my scene out ?

Ah, I see what you mean now. Did resizing the window do anything for you?

I’ll look into it soon.

rendering window matches viewport size :+1:

This is due to the DPI setting you are using. Make it 72 and the image won’t be cropped. If you want a larger image, increase the pixel dimensions with the Custom option in the drop down. I think this shouldn’t happen though and thanks for the report, I filed it as https://mcneel.myjetbrains.com/youtrack/issue/RH-57806

3 Likes

Cheers Brian, yeh it makes no sense that the image gets cropped if you up the DPI to something like 144. Look forward to the fix :+1:

RH-57806 is fixed in the latest WIP