Render mesh shading anomalies

In the file attached the render mesh in fast and slow settings shows weird delineated shading anomalies (see pictures below). The only way to get rid of this is to manually change the mesh settings.

The shape is very simple: the curve in the revolve layer is revolved over 360 degrees. Then the curves in the trim layer are used to create holes in the revolved shape. It seems that the shading anomalies occur due to the very large shape anisotropy in mesh faces on the flat part of the revolved shape.

Is there a reason why this happens? Can I prevent this somehow without changing the mesh settings?


hub.3dm (775.2 KB)

Hey Menno,

That thing is a single creased surface… That almost always causes meshing “anomalies”… How did it get that way? Do you accidentally have crease splitting turned off? (CreaseSplitting> SplitAlongCreases=Yes/No)

If you run the command DivideAlongCreases on your object and set SplitAtKinks and SplitAtTangents to Yes, it will look nice again… :smile: :

Cheers, --Mitch

Oh yeah! We usually work with CreaseSplitting=Off because of the knuckle lines in most ship surfaces. Otherwise they cannot be edited properly by our CAD engineers.

Thanks for finding that :smile:

@dalelear maybe the Rhino mesher needs to be able to deal with creased surfaces better…?

http://mcneel.myjetbrains.com/youtrack/issue/RH-29044

thanks!

-Pascal

@pascal I don’t seem to have access to the Youtrack item but I am logged in on your Youtrack site. Could you make the issue public, seeing as it originated here? thx

Done. Sorry, I thought I had set it up that way.

-Pascal