Render distortion


#1

HI,
I CANT GET WHY WHEN I RENDER THE IMAGE THAT I GET IS DISTORTED OR NOT THE ONE THAT SET ON THE SCREEN …

HOW DO I SOLVE THIS ISSUE ?

THIS IS THE VIEW PORT;

THIS ID THE RENDER WINDOW;


(Andrew le Bihan) #2

Which renderer are you using?


#3

HI ANDY,

I AM USING V-RAY 2


(Andrew le Bihan) #4

Almost certainly the reason is that VRay doesn’t support 2-point perspective. However, I will let the experts on VRay take over from here.


(Brian James) #5

I just tested two point perspective in the perspective viewport as well as an orthographic viewport and they both match the viewport. My hunch is that your Vray camera settings have a setting that is causing this but I’m not able to reproduce the problem. Try loading the rhinodefault visopt file to see if that’s it.


#6

YEA I CHANGED IT AND IT WORKS…
SHAME IT DOESNT WORK WITH 2D PERSPECTIVE …

BRIAN, DID YOU MAKE IT WORK USING VIEW PORT PROP. - 2 POINT PERSPECTIVE - ?
CAUSE THATS WHERE THE DISTORTION CAME FROM

THANKS

PS
EVRY TIME I TRY TO REPLAY TO THE CHAT I GET A MESSAGE THAT I HAVE TO EXTEND MY TEXT - THAT WHY I ATTACH A PHOTO … WEIRD DAY
’Body is invalid; try to be a little more descriptive’


(Brian James) #7

Yes, that appears to work here.


#8

Yes, still comes out distorted …


(Rob McPherson) #9

I think you need to run this command before you press render - _visGuessLensShift
This will give you vertical verticals (if you know what I mean).
If you change camera then you’ll have to run it again.
It changes the lens shift parameter in the Physical Camera tab.


#10

A M A Z I N G !!!
Thank you it worked !


(Rob McPherson) #11

My pleasure!


#12

Thanks a lot


(Rob McPherson) #13

No problems!

This command is also available on the vray extra menu - see below…


#14

amazing.