Render curves and surface edges Rhino 4 style


#1

Is it possible to change render style of curves and surface edges in Rhino 5 (default render engine) to be like in Rhino 4?
By default they’re so heavy and coarse, they’re almost useless.
Pic to explain:

R5

R4

I checked manual, under “render curves” they’re those 2 pics

<a href=‘http://postimage.org/image/661rrl9ln/’’>

so I believe it looks how it should and was coded in Rhino, but… Jesus why, it looks terrible.
Any way to change it to Rhino 4 style?


(Pascal Golay) #2

Hi Hav - you can set surface edges to one pixel, rather than two in the display mode settings, and you might also want to turn on anti-aliasing in Options > View > OpenGL page. 4x should be enough to help.

-Pascal


#3

What you suggest will help in wire, shaded, rendered etc. viewport but it does not affect the render (and by render i mean ! _Render). I tried this already. Also AA in OpenGL seems to affect only viewport, and AA in Render settings doesn’t help either.
Those pics I posted earlier shows rendered image of curve and surface and here is the problem - it looks very heavy in Rhino 5 compared to Rhino 4 with same option in Render settings (Render curves, Render surface edges and isocurves - both selected in R4 and R5).


(Andrew le Bihan) #4

I just noticed this a couple of days ago. Something must have gotten broken in a service release somewhere. We’ll get it fixed.

Andy


#5

Many thanks.