Removing "self shadows" for rendering

I am trying to render a couple of models without “self shadows” (if I understand this term correctly)

This is what I want to render:

And this is what the render looks like:

I can’t seem to be able to get rid of the shadows.

I have gone to Render Settings > Advanced, where there is a section called “Preventing self shadowing”. I have played around with the numbers in that field but that does not seem to do the trick.

Is what I want even possible? And if so, how do I achieve it?

It looks to me like you’re comparing the “Shaded” working display mode to a simple Rendering that is using default materials.
These are two very different things, like apples and oranges.

If it’s just the shadows you want off, then select your objects, and in the Object Properties panel. uncheck the option for Casts shadows.

The Shaded working display mode also draws surface edges and seams. There is a control for turning those on in the Render Properties tool in the Miscellaneous section.

Shaded display also uses a glossy “material” and an environment to give the effect you are seeing.

Thank you!

That is not what I meant. I was not comparing the two. I know that I can create a similar image without shadows in the Viewport Display (View > Rendered) as in the second posted image one by changing the Viewport background to white (Rhinoceros > Preferences > Colors > Viewport colors > Viewport background), and by removing the display of the grid lines, grid axes and world axes icon ( File > Settings > Grid)

However that was not what I was after. I wanted to Render > Render, since for that I can also choose the level of Antialiasing.

I did not know this. I was looking in “Viewport settings”, where “Shadows” is greyed out. And as I mentioned I had gone to Render Settings > Advanced, where there is a section called “Preventing self shadowing”. Changing the value there does not seem to affect anything.

This I know. I was looking in the wrong place to turn “Cast shadows” off.

Now I have a new question. What is this “Preventing self shadowing” setting for? What does changing the value do?

That setting has nothing to do with what you were attempting, but here the details from the Help file describing that control:

Preventing self-shadowing > Ray offset:

Prevents self-shadowing artifacts. When the intersection between the eye ray and the scene is found, the intersection point is moved (offset) towards each light before calculating the shadow ray. The reason is there’s always some numerical fuzz in calculating the intersections, and if the point is not offset, the shadow ray might hit the very same polygon again, putting shadows in wrong places. You can see the self shadowing artifacts if you set the setting to zero, and then render the scene.

I do not understand this.

I see no difference in the shadows of this particular scene whether I have the Preventing self shadowing > Ray offset set to .0001 (the default) or 0.

Is it possible that I do not see any difference, because I have no material added to the individual objects? I.e. I am just rendering with the default materials, therefore no shininess, reflections, etc.

Could you please upload a sample file in which I can see this clearly so I can understand this better.

I am positive this tool has nothing to do with the effect you need.
It is for some other special need in dealing with visual “artifacts”, or odd little glitches in the calculation of shadows.
Since you don’t want any shadows, the appropriate tool are the “Casts shadows/Receives shadows” control on the Properties Panel.

If you’re still interested, @jeff or @steve may be able to describe the “Preventing self-shadowing > Ray offset” tool. I’ll check in with them.

Your use of the term “Self-shadowing” is not the same as Rhino’s… Self-shadowing in Rhino is where any given render mesh will cause shadows to be cast onto its own triangles or set of triangles… It does not mean that given a group of surfaces that can be visually identified as looking like a single object, to not cast shadows.

What it sounds like you want is to just turn off shadows altogether for a given light source. Select the light, go to the light’s Properties, and turn the Shadow Intensity down to 0%


You are correct, I misunderstood that term.

Does this to mean, that this only applies as relating to shadows of meshes and not NURB objects.

There were no added light sources in the scene. I was working with the default light. Since this light source cannot be selected, the shadow intensity can also not be set to 0%.

When rendering…everything is a mesh, including NURBS objects… Rhino creates “render meshes” for all NURBS surfaces… When you see shaded NURBS surfaces in your viewport, you’re looking at shaded, rendered meshes.

You are correct about the default “headlight”… But just add a Directional Light to your scene and select it and change the shadow intensity on it.