Remove plugins completely

unhandled

#1

I searched google but cannot find a solution. I tried a few plugins (visualarq, vsr, etc.) but after the trailtime was up and i removed them with windows uninstaller they are still in my menus and i cannot get rid of them. if i click any of the commands its shows up as unknown command. they do ot appear in any plugin list anymore. what do i do?


(Steve Baer) #2

Depending on the plug-in, they may ship with an uninstaller which would likely show up in the start menu for that plug-in.

Otherwise you can run the “PlugInManager” command in Rhino and uncheck the enabled state for those plug-ins. This will make these plug-ins not show up the next time you start Rhino.


#3

thank you for the answer. I used the uninstaller. So ex. VisualArq is officially gone. That means it also doesnt appear in any pluginlist. Any suggestions?


(Steve Baer) #4

Let me make sure I understand. You used the uninstaller for VisualArq, but it still shows up in Rhino. Is that correct?


#5

correct. It is still in the top menubar. I can also add the toolbar still but if i click any command it shows as unkown command.
I just want to delete the menupoint since i cannot use any commands anymore.
I just cannot find any traces of Varq anywhere. Not in the windows uninstaller nor in the pluginfolder or pluginmanager neither.
thank you.


#6

fixed it.
deleted files in C:\Users\Name\AppData\Roaming\McNeel\Rhinoceros\5.0


(Steve Baer) #7

Wow, that seems like a pretty extreme solution. @JohnM, it sound like the toolbar/menu definitions stuck around after VisualArq was uninstalled. Is there anything we should do to fix this or is this something that needs to be handled by the plug-in’s uninstaller?


(John Morse) #8

My guess is there is a RUI file somewhere that contains the tool bars and menu definition that did not get uninstalled. The other thing that can happen is tabs from the VisualArq RUI collection can get dragged into the default RUI collection which means an uninstaller will never be able to get rid of them. The menu issues defiantly sounds like an RUI file.


(Steve Baer) #9

I wonder if there is anything we can do for V6 to make this cleaner? It seems like a pretty annoying bit of junk to have to clean up.


#10

I also had the same issue with VisualARQ and the menu hanging around after uninstall.

JohnM is correct about the RUI file hanging around. It can be found in C:\Users[username]\AppData\Roaming\McNeel\Rhinoceros\5.0\UI if they want to remove it manually.


#11

Steve,

I understand this is an old topic (Sept 13) but it would be very helpful to have clearer methods for installing and uninstalling plugins.

A button in the plugin window for restoring a default (as per the tool bar restore defaults method) would be great!


(Akkuratnov) #12

deleted some files visualarq in
C:\Users\user\AppData\Roaming\McNeel\Rhinoceros\5.0\UI
and after all its disappear from top menubar


#13

Thx for the advice!
Was having related issues with Iray v1.5 plugin.
Whenever v1.5 was enabled/installed, my panel configuration (layers, properties, etc vertical-config) would reset to default configuration (properties, layers, display, help–horizontal config).

I think they might have been caused by an incomplete uninstall of Iray v1.4 (vendors changed from Nvidia to Migenius–who are great, btw), as the old iray v1.4 toolbars were sometimes still appearing.

I deleted the contents of this folder (per your suggestion above) & I think it seems to have worked.
C:\Users*\AppData\Roaming\McNeel\Rhinoceros\5.0\UI\System


#14

–just kidding. didn’t work in the end…

EDIT:
Start Rhino v5 as admin, set panels as desired, restart & run as typ user/regular launch. “duh”. :wink:
Not sure what’s up with my Win7x64pro reinstall, but def a glitch I haven’t had to deal with before.