Remove non planar extruded object from another non planar extruded object


If I have a polysurface with a non planar plane. I am projecting shape on it, that would represent constructed lot. How can I remove (boolean difference) the lot shape from the overall land shape ? When I extrude a non planar form, it cannot be cap as a closed polysurface so I cannot remove it from the main object. I am able to achieve what I want but I have to split the shape, extrude the edge and then move the top to the bottom. Quite long when you have a lot of shapes.

When all the object are planar, this is so much easier.


This is what I am trying to achieve, but several times.


Hi gimmy- Split, then ExtrudeSrf (DeleteInput=Yes), -or GumballExtrude- then ExtractSrf & Delete the top face of the result. Maybe slightly better.

Better yet: SplitFace > Curves option, then subobject select the split out face and Gumball Extrude (Hold Ctrl down before fininsh the Gumballing) downward.


quite faster. Thanks.

Still trying to simulate a city base with plot (sidewalk). The method proposed by pascal works quite well except when I want to trim the excess of the patched surface. Whenever I do it seems to change the surface and it creates strange shape that overlap the lot. I include two image and the file if anyone want to try and has a clue on how to solve this issue. Thanks.

file is to big to attach. sorry.

Is it still too big if you ShrinkTrimmedSrf and ClearAllMeshes on the objects?
At any rate, it looks a bit like the red surface shows through the gray surface because they are very close to one another.

You could try to change the mesh settings and/or play with TestZBiasFactor.

Will try. What I do not understand though, is why the surface is perfect before the trim and then modified after. Same thing happen if I try to extrude the trim limit and substract one from another. Same result, top surface as some bumps.

shrinktrimmedsrf seems to have done a good job. I do not understand what it really did though…

When you trim that object, a entirely new display mesh is created. The NURBS surface in that area is still the same but what you see is a 100% new object.

Shrinking the NURBS object changes the start-point for the meshing process and as such the new display mesh will be different as well.

Note that shrinking gets rid of the information about that surface beyond the trimming curves - you now cannot go back to the original surface by calling Untrim. So if it is important to be able to get back to this, you should either incrementally save now or undo and make a copy of that surface and hide it on a backup layer that is off.

Thanks wim. Really usefull.