Relocate Gumball doesn't save position in Rhino 8

In Rhino 8 when relocate the gumball and save, the gumball will go back to its original position when the next time the file is opened. In previous version the new location was saved.

Hi Chad - so far this seems to work as expected here. Can you post a simple example file with an indication where the gumball should be?

-Pascal

Here you go. I saved the file after relocating the Gumball to the positions shown below. When the files is opened they are back in the center of the object.


Relocated Gumballs

Gumball after saving and opening file

gumball.3dm (90.4 KB)

Hi Chad - this works here - that is, your file opens with the gumball centered but if I move it and save, it reopens with the moved one.
gumball (1).3dm (94.9 KB)

. Ah - block instance. Can you repeat the problem if the selection is a polysurface?

-Pascal

It’s doing it with the polysurface as well. When I open the file you posted, the gumball is in the center of the block (triangle) and the line (which is not a block).
We are experiencing this on 6 separate machines.

gumball (2).3dm (140.8 KB)

Hi Chad - please run SystemInfo in Rhino and copy/paste the results here…
-Pascal

Rhino 8 SR5 2024-3-12 (Rhino 8, 8.5.24072.13001, Git hash:master @ e3530849b75f00b2b977766a567ae29b055837e9)
License type: Commercial, build 2024-03-12
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 128GB)
.NET 7.0.17

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 Ti (NVidia) Memory: 8GB, Driver date: 9-12-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.42
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-12-2023
Driver Version: 31.0.15.3742
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
G:\Castaneda Engineering\CAD References_Commands\Rhino\RATplus_071118\Rhino\RATplus_071118.rhp “Rhino.NET SDK” 0.0.0.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hi Chad - thanks… a long shot but can you please try blocking these two plug-ins in Options > Plug-ins page:

Rhino plugins that do not ship with Rhino G:\Castaneda Engineering\CAD References_Commands\Rhino\RATplus_071118\Rhino\RATplus_071118.rhp “[Rhino.NET](http://rhino.net/) SDK” 0.0.0.0 C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Then close and re-open Rhino - does this make any difference?

-Pascal

It still occurs. I disabled all the plug-ins that do not ship with Rhino, closed rhino. Reopened the file and relocated the gumball. Then saved and reopened and the gumball reset to the center.

@chad1 This file opens like this in Rhino 7:
gumball-location-rhino7.3dm (218.2 KB)

And this file opens like this in Rhino 8:
gumball-location-rhino8.3dm (174.2 KB)

What I do see is that the Rhino 7 file opened in Rhino 8 shows this:

When I opened your file the gumball was in the center of the object. Do you get that as well when you open the one I posted? (the version 8 file)