Registry entries for installed plugin

I’m installing a plugin, but I can’t find the proper combination of registry keys to make Rhino recognize the plugin. I can manually go into the plugin manager and install the plugin and the menu shows up and works well, but the toolbar doesn’t appear. I can install the toolbar manually and it works fine, as well.

I’ve done these manual installs, scoured the registry to find the keys that mention my .dll, and made those entries programatically, but still no menu or toolbar.

How do I make the install set the proper keys to “announce” the plugin and toolbar to Rhino?

Hi @cestes001,

Can you reviewed this information?

– Dale

Thx, Dale. That looks promising, but I’m afraid that, until I can get the plugin to load, the .rui file will have to wait.

Currently, I’m forced to run the install program to install the plugin, which copies the files to the proper location and registers the activex dll. However, when I open Rhino, there is no indication of the plugin.

When I open pluginmanager, The plugin isn’t listed and I have to “install” it. It still doesn’t show up in the menu. Ocassionally, I can get it to show up in the menu (don’t ask how - IDK), but when I close/re-open Rhino, the menu item is no longer there.

I’ve been struggling with the registry entries for a week and i’m pretty well convinced that’s a dead end.

Is there a preferred location to which I should be installing the plugin where Rhino might automatically find it?

In the link, there is mention of %APPDATA%. Is that, perhaps, where i should be installing the plugin? If so, what would that path look like in a typical installation?

Hi @cestes001,

Rhino does not have a location that will automatically load plug-ins from.

More on plug-in registration.

– Dale

@dale , @JohnM
do you know will this .rui file workflow still be valid for Rhino 8? I believe last info regarding toolbars in v8 is here: New UI: Text along with tab icons? - #9 by JohnM

Hi @mlukasz87,

With V8, plug-in RUI files now automatically load on both Windows and Mac.

Is there something else your looking for?

– Dale

Hi Dale, thank you for response.
I was too quick and did not describe problem well. Toolbar is loaded but menu from .rui is still missing. Will rui files in v8 support menus like in v7?

Probably I should create new topic for this question.