Region Slits doesn't seem like to be slitting all

Hi! I am using GH and Rhino for Mac, I am trying to use RSlits for my project but it skips few of the planar surfaces that I created. I tried to find solution for hours. I am wondering if it is a bug to be fixed? is there any limitations for that particular node that I don’t know yet? or even I am making a mistake which could be fixed by some of your help?

I’ve attached the file below. Thanks for your ideas.


geo deneme.gh (26.8 KB)

Download OpenNest

There is the same region slits component.
I had to decompile, then project curve to an average plane to make this error go away.

This is and old issue shown in old grasshopper forum, without solution.

try this:
geo deneme.gh (43.1 KB)

yes…gh doesn’t like common sense :grin:

*you might need to flatten Rslits input…

2 Likes

Thanks for your help but I believe it doesn’t quite work on Mac OS platform. But I’ll consider to use this in Windows based computer.

Firstly thank you it solved my problem entirely. I am not a technical person so to be sure was my approach on this wrong?