Reflected ceiling plan and Plan Hatch Issues

I’m in need of generating a reflected ceiling plan but can’t seem to figure out a way of doing it? Is it currently possible? Also on the topic plans, I’m unable to get the hatch to appear in the plans. I’ve changed the Plan View Settings but the changes don’t seem to update the plan drawing. Even tried selecting the plan and clicking the update button.

Hi Scott, right now there are no specific tools to generate Reflected ceiling plans. I add a vote from you to this feature for the future development.
Regarding Hatches in plans, the hatches as section attributes are assigned by object individually (from the section attributes icon, in the Properties panel) or by object Style (from the styles dialog, in case of VisualARQ objects). However the section attributes of Section View and Plan View styles don’t affect the 2D drawings (although we have plans to add an option to override the section attributes by Section/Plan View styles). In this page you can find more information:
If there’s something that doesnt’ work as it should, please let me know it.

1 Like

An RCP is just a floor plan with all the floor finishes, furniture, joinery, doors, etc turned off & a ceiling model shown… right?
Scott can probably hack something together using layers? Right @fsalla ??

Well… It sounds like it’s a section cut right above the ceiling without the ceiling getting in the way of seeing the floor. Many people have tried to explain it before :wink:

In the thread above, @SamPage also has an image of one:

Well, you actually don’t see the floor. You see the ceiling… :stuck_out_tongue_winking_eye: --M

Yeah that’s part of the issue, there doesn’t seem to be a parallel to any workflow within any other design stream outside of the Arch/mech/hyd space.
Helvetosaur is right, it should look upwards.
The issue I see with it being a downward facing section cut above is that not all partitions/walls continue past the ceiling… perhaps you could have the ceiling model 60% transparent… but we’re entering hack-ville.

My suggestion is equally faulted; if you use a floor plan and ‘fake’ the position of a ceiling so that it’s visible within a floor plan then control its visibility in each view with layers you can’t export the model to anyone else on the team because the fake ceiling position isn’t correct…

Perhaps this is an issue only while we straddle these mixed model/paper deliverables too?

Managing the elements that appear in the RCP by layers could be a hack solution. Also playing with the Level Cut Plane height in the Level Manager (from where the plan views are created) or the View depth value from the Plan View properties, could help.

I wouldn’t consider it a layer problem, but a view problem. What I have always done to get RCPs is insert the model as a linked block into a new file which will serve solely as the RCP file. Then mirror that block about the X axis, so it is flipped top for bottom. Then you set a viewport to bottom, drop in a clipping plane at the same height as your plan cut, and you have it.

@jeff had a quick plug-in he wrote that flipped a viewport top for bottom that showed great promise, but had some pronounced bugs in layouts, and it didn’t survive closing and reopening Rhino. I don’t think he got enough feedback on it to justify him working those bugs out, but it felt really close.


@Scott_Crawford the workaround I have found works ok but it would be ideal to ultimately have an floor plan style option to flip the view depth. It also would be helpful to have the option of inserting and tagging lighting fixtures and other ceiling elements.

My current workaround involves creating a clipping plane at a height that intersects the door/window head trim if possible. Then setting a view window to face bottom instead of front, right, etc. You likely will have to flip the clipping plane in order to see in the proper direction. Now do a Make2d of that view, group the geometry and move it into place on a VAplan with unneeded layers hidden on the sheet. Rotate the Make2d element 180° so that it aligns with your plan. Use the automatic “clipping planes” layer from the Make2d in order to line it up correctly and then hide that layer if you don’t need it for door openings and such. Hope this helps.

1 Like