Referenced & Linked block improvements

Hi,

I have a suggestion for linked blocks, similar to what overlay (as opposed to attach) does in Autocad. It happens to us fairly often, that we would like to have certain geometry linked to the base file purely as a drawing reference, however, we don’t want this referenced geometry to remain in the file if the base file is linked further.

I know worksession works in some instances for what I am describing, but it has other limitations (fixed origin, no activer layers…).

I think it should be a simple thing to implement - perhaps checkbox overlay in the block menu - and could save us quite some trouble.

This simple thing would also make worksessions redundant in my opinion as linked blocks seem to be the preferred way to reference geometry anyway.

Thanks.

1 Like

Hi -

It sounds like that is solved by unchecking the Read linked blocks from the file setting when inserting the base file in a more top-level file?
-wim

Hi Wim,

I googled your solution and was surprised to find that indeed there should be a checkbox “Read linked blocks from the file”.

In my version of Rhino (Version 7 SR20) I don’t see this option though… Did it got removed (moved?) at some point and why?

A further improvement would be for Rhino to differentiate between attached and overlayed xrefs. In a big architecture project like we are doing this would make quite a difference.

Thanks, Denis

Hi Denis -
Please run the Rhino SystemInfo command and copy-paste that information here.
-wim

Hi,

Rhino 7 SR20 2022-7-12 (Rhino 7, 7.20.22193.09001, Git hash:master @ 9b19bfdb8c343dd6fa8df3514068defd72273d6f)
License type: Commercial, build 2022-07-12
License details: LAN Zoo Network Node

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A2000 12GB (NVidia) Memory: 12GB, Driver date: 10-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.47
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
Intel(R) UHD Graphics 770 (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2021
Driver Version: 30.0.14.7247
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12282 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Dennis - that setting appears during the Insert process:

-Pascal

Hi Pascal, Wim,

I was trying to figure out what is happening because there simply is no option like this in my case. Then I realized it might be because I am trying to link a .dwg file. Indeed when I try it with .3dm file I can see this checkbox.

Maybe I was a bit unclear in my original post. What we are trying to achieve is a linked dwg file, which my colleagues are updating in Autocad and I have linked in my Rhino. When trying to make this link work, we experience multiple difficulties, that we would be very helpful if they were addressed:

  • There is no way to exclude files that are referenced into the dwg (xref) from importing to Rhino. Ideally there would be a way to have a checkbox like with Rhino files (or even to differentiate between attached and overlayed AC xrefs)
  • Dynamic blocks often cause problems. Rhino should read them in their current state from Autocad. Something like exploding and then creating a unique block for each state should be the case.
  • Arrays similarly confuse Rhino and the solution should be similar: exploding and creating a unique block from each unique array.

I think in architecture, linking AutoCAD to Rhino is still a very common workflow, so these difficulties would be quite important to address. I have already seen some of them requested in the past.

  • Denis
1 Like

Hi Denis -

  • Having xrefs regarded as linked blocks is on the list as RH-57627.
  • Support for dynamic blocks is RH-51073.

Could you post an AutoCAD file with an array that confuses Rhino?
-wim

2 Likes

Hi Wim,

Thanks, we appreciate that.

I recreated the problem we had with the arrays. AC arrays seem to have a unique name (format *U00). The problem appears when you import multiple autocad drawings containing arrays as they create blocks with identical names in Rhino and containg the wrong geometry.

Please try to import those two files (one with arrays of circles, other with lines) to see the issue.

array test 2.dwg (35.3 KB)
array test.dwg (53.4 KB)

Hi Denis -

Thanks for those.
When I uncheck the Import unreferenced blocks option when importing the DWG into Rhino, it appears that everything gets in as expected.

image

Does doing this conflict with anything else that one might import?
-wim

Hi Wim,

That works well for me so far, thank you!

Could you explain quickly what unreferenced blocks are?

Thanks, Denis

The AutoCAD Array command has an option for Associative Array.
If you are the one doing the Array, you can set Associative to No.

Command: ARRAY
Select objects: 1 found
Select objects:
Enter array type [Rectangular/PAth/POlar] <Rectangular>:
Type = Rectangular  Associative = Yes
Select grip to edit array or [ASsociative/Base point/COUnt/Spacing/COLumns/Rows/Levels/eXit]<eXit>: AS
Create associative array [Yes/No] <Yes>**: N

If you are importing a DWG that was already created this way, Wim’s solution at import is good to know about.

Sincerely,
Mary Ann Fugier