Record History for Project doesnt work

I was projecting some red color curves (1) - while recording history - to a plane surface (2), resulting in the leaf rust curves (3), but

… when I try editing the red original curves (1), the leaf rust curves (3) does not update, nor do they (3)
update if I try to change the curvature of the surface (2).

I can see in the cmd line a message saying that history was updated, but I can’t see any such change. The expected change of curve 3 should reflect the gross distortions of the curve at 1 and/or the surface at 2.

I started Record, then typed Project, then selected curve (1), and then surface (2), and so on, but no go, although Rhino reports that it has updated um… something, but I don’t know what.

What am I doing wrong?

Edit: Hm, can it be because the projected curves (3) are not on the same layer as the original curve (1) nor the surface (2)? (three different layers)

// Rolf

Is History panel > Lock children checked by any chance? --Mitch


Dunno, seems to be working here… --Mitch

OK, I tried again, and this time it worked. Perhaps it failed last time I tried because I changed Viewport during the recording?

Strange though how Rhino reported that it had updated history, while no change was visible. Oh well, at least I can move on now.

// Rolf