Reboot required by Installation of WIP V7

Installing yesterday’s Rhino WIP 7.0.20112 for Windows required my system to reboot before the installation could proceed. A few minutes before I had installed Rhino 6.25 Release Candidate 25 (6.25.20112) for Windows without any problems. I usually install the latest WIP V7 release and V6 SRC/SR every week and don’t recall ever having to reboot the system.

Any idea of the cause? Was this intentional with this release of WIP V7?

Rhino 7 SR0 2020-4-21 (Public Build, 7.0.20112.12445, Git hash:master @ 86276bc12c444fd48d1645bda74a385a1118fb03)
License type: Commercial, build 2020-04-21
License details: Cloud Zoo
Expires on: 2020-06-05

Windows 10.0 SR0.0 or greater (Physical RAM: 12Gb)

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 11-15-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 860M (NVidia) Memory: 2GB, Driver date: 4-3-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 445.87

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-3-2020
Driver Version: 26.21.14.4587
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20112.12445
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20112.12445
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20112.12445
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20112.12445
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20112.12445
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7 WIP\Plug-ins\Calc.rhp “Calc”

My guess is that Rhino was installing an updated .NET framework, your’s was running and in use at the time, so Windows staged the update requiring a reboot.