Reading different ifc informations between "save as" and "export selected"

when I try to “save as” and “export selected” 3d model in ifc file, this is read in different way between the two save options (I used Solibri).
Thank you

Hi @fn_a, can you share the 3dm file and the two ifc file versions so I can better understand the differences when opening the files in Solibri?

Hi Francesc,
Here they are. The strange thing is that when I try different ifc viewers (XBimXplorer, Bim Track) some of them do not read (not visualize) in the “save as” mode the windows, doors and extension walls, on the contrary instead of “export” mode where they read and visualize but a limitation’s informations.
Thank you!
test_ifc.rar (1.8 MB)

I’ve opened your ifc files n Solibri, and I just appreciate a different color of the roof, as the only difference between the two files. (Maybe you changed the color of it after the first export?)
I’ve tried exporting the 3dm file to IFC myself with these two methods (“save as” and “export selected”), and I see exactly the same in Solibr or in Revit. So I don’t know how to help you.
Which Rhino and VisualARQ version do you have? Make sure you are running the last VisualARQ version (2.9.1). And always make sure VisualARQ is loaded before exporting the file to IFC, no matter which way you choose.

I have also checked how the model opens in xBimXplorer (not Bim Track though), and I only see the slab and roof. All geometry (walls, windows, etc…) seem to be there, but they are not displayed. I guess this is an issue on that software side, since Solibri, Revit, or VisualARQ reads the IFC properly.

Thank you Francesc,
I attached screenshot that I see in Solibri and I keep seeing different informations…
I try Visualarq 2.9.1 (last version) and Rhino 6 SR.19 (6.19.19295.1001, 10/22/2019).screenshot.pdf (742.3 KB)
Thank you again.

After your suggestions I tried to load manually the ifc plugin, and when I try with a export plugin I have this message. could this be the problem?

Many thanks

PS. I managed to upload it, but the problem persist. I tried to open ifc file also in bim vision with the same results…

Hi, you are right, there are many data that seems to be not stored in the file with the Export Selected option. We will revise this.

I think that message is not relevant. The IFC import and Export plugins should load as soon as VisualARQ loads, so there’s no need to do it manually.

Thank you Francesc, I hope that you solve this problem as soon as possibile.