Read-only file

Did the NAS admin person install an SSD into it?

Otherwise, maybe the product specs will show that info (hopefully) …

Yeah, or failing that, it would be a question of logging into the administration control panels. I’m not familiar with Promise though so I can’t really provide much input on exactly what is needed.

Interesting suggestion from @gurney1 in this thread: Rhino 6 mac file will only open as read only

Our NAS does sync with dropbox.

Could this be linked with the major performance issues experienced when closing a file and choosing ‘revert’ rather than save? See here: Major performance issues in V6

It seems to me that something non-standard is going on with the way Rhino is handling files.

Hi guys, dont know if anybody noticed before, anyway. Open read file issue disappears when you open the file from Rhino. Does it work for you as well? There might be something weird happening…

I think I got it:

  1. When opening a file WHILE it is visible in the finder preview pane, the read-only problem is invoked.

  2. When the file is not selected (the preview of that file is NOT active), and you drag the file onto the Rhinoceros icon in the dock, there’s no problem. You could also disable the finder preview pane by hitting cmd-shift-P and just select the file / double-click it: either no problem.


So, it’s the finder preview pane “looking” at the file and blocking it while Rhinoceros tries to open it for editing.

Hope this helps, @dan!

3 Likes

Cool!

1 Like

On one test/computer we could avoid the read-only problem by disabling the finder preview pane only. — Unselecting and dropping the file onto the Dock icon on that computer didn’t work.


On my machine, though, both solutions work with server files as described in my previous entry.


By the way, @dan, do you see the cause of the problem?

Hi @dan.

Is anybody working on that problem?

Hi - our bug-tracking system is (mostly) open to the public and you can check for activity from the link provided in this thread by Dan on August 15th.
-wim

1 Like

The YouTrack Link RH-53222, for reference.

This is really interesting. Let me see if this is what you’re describing:

  1. Start Rhino 6 for Mac
  2. From the File menu, click Open
  3. In the Finder window, select “Show items as Icon”:
    image
  4. Select a 3DM file to open
  5. Rhino opens the file with the Read Only warning

If you replace step (3) with “Show items as List”, this problem doesn’t happen?

If this is the case, then I speculate that there’s a combination of things happening:

  1. The thumbnail preview reader is opening and locking the file on your NAS
  2. When Rhino tries to open the file, it sees that it’s locked, and gives you the warning

I think this is happening because of a QuickLook plug-in that we ship with Rhino; I have no idea how to disable it - do you?

Seems you’re misunderstanding my steps, @brian.

I was describing opening a file from the Finder.app, the Rhinoceros.app (optionally!) being closed at first.

NOT from Rhinoceros.app’s “Open File” dialog, but from the  Finder application, e. g. double-clicking the file (and, concurrently, activating that file in the Finder.app’s preview pane).

Excellent, that’s why I asked! So I have a couple follow-up questions for you:

  1. Does Rhino open files without the read-only warning when opened from the File menu?
  2. Does it make any difference if you follow the steps I’ve outlined, above? That is, does it work when the File Open window is showing Icons versus List?

Also, is it 100% consistent that this problem goes away when the preview window is closed?

  1. Yes.
  2. No, it makes no difference. Files will always open without interruptions.
  3. Yes, when the preview PANE (not window) in Finder.app is de-activated, the error is not showing up.
  4. But: the other way, IF the file’s preview pane in the Finder is active and you try to open it from Rhinoceros’ Open File Menu, the error “read only” comes up again – consistently.
  5. If you trigger quicklook in the Rhinoceros - Open File Menu, “read only” also comes up again (Quicklook has to be active when clicking the “Open” Button to trigger the error).

I was just able to reproduce this here. I’ll add the new steps to the bug report. Thanks @msmr!

1 Like

Hi @dan
Is there any news coming regarding this issue?

:eyes: