Read-only file

Can confirm the same behavior here as well.

I’m having issues again too with:
Version 6 WIP (6.16.19191.20064, 2019-07-10)
Expires August 24, 2019

Having restarted both my Mac and the Synology NAS, the files are now opening correctly. Stupidly, I should have tried one at a time so I’m not sure if it was Mac or NAS related.

Incidentally, we have a READ SSD cache set up. Could this be influencing things? I think when the NAS is restarted it wipes the cache.

Do others with this issue also have an SSD cache set up?

YES, we do. — Not sure what can be done about this error (if the cache is it), because for reading files fast the cache is being made for.

I´ll test that tomorrow morning, to not interrupt my colleagues … :grin:

Because our NAS isn’t restarted daily, AND my colleagues reported the error occurred on almost any file, I’d suggest it’s the NAS restarting what’s actually helping …

I spoke too soon. The first file I opened was fine, but after that, they are opening as read only again.

Given it is only ever an issue with Rhino, hopefully identifying if it is the SSD cache that is the specific problem area could help with finding a solution.

Re other users, I just waited until lunch to test it but yes, it is difficult sometimes and we typically only restart for software updates!

Incidentally, in trying to open and close a series of files, this warning came up. At the time I only had 2 ~85MB files open. I think there is still a memory problem.


It also failed to quit when hitting the quit button. I had a blank main window for rhino (grey) and a white rectangle floating over the screen somewhere before I force quit.

Edit: found the cause and it wasn’t Rhino

That didn´t belong to the “read only” problem?

Sorry, I can see how the way I’ve edited the above is confusing. My original post was this:

I’m also coming across a weird, perhaps related issue.

I’m trying to import a DGN file into Rhino. The DGN has been updated. We’ve double checked on two machines and it is showing correctly.

However, when importing into Rhino, an old version appears. It is obvious because the newer one has had a LOT of geometry removed from it.

Is there something funky going on with the way that Rhino is reading files when an SSD cache is involved? Are we somehow getting an old, cached version rather than the current one? Could this be linked to the read-only file situation?

Saw it.
investigated the “edit key” on your post. Thanks though!

1 Like

Hi, is anybody from McNeel looking into this issue? Any ideas?

1 Like

That would be cool. :cool:

Hi @dan,
do you have any updates on this? Have you been able to reproduce this issue somehow? All of us in our office are experiencing the same issue here. Just mentioning, we have no problems with Rhino 5 and also some of the wip versions of R6 were exempt of this problem. Or is there anybody else who solved this issue within their NAS settings?

Same here, too.
5 Licenses, all with read-only problems opening from our fileserver (QNAP NAS).

That would be interesting. I don’t think so (yet).

It is intermittent for us. I certainly think that restarting our Synology NAS helped.

Sorry, I don’t have an update on this. Is this the same failure as recorded in RH-53222 Synology NAS file saving failures? (this topic?) It seems like it, but I want to make sure.

Hi @dan, yes it is this issue. The only difference is, that we have Promise NAS

Yeah, I think it is clear from this thread that it is happening with various makes of NAS. The thing I’m wondering though is if it is happening only with NAS drives that are using a SSD read cache.

1 Like

Does your NAS also use a read cache?

I wish I knew…not an IT guy when comes to this. How can can I find out this??