Raytracing Rhino Mac 7 WIP

Why does raytracing not always work with certain drawings but works with others? Is there any way to control how materials are applied to an object other than using the UV tool after applying surface textures?

Hi @Joe_Neill,

Can you please elaborate the issues you are having? Are here two different issues at play? It’d help if you have examples with current result and what you’d expect.

Hi Nathan,
The first issue is with raytracing, I brought in a drawing from 6 to rework it and raytracing seemed to work much better. I brought in a second drawing from 6 and raytracing did not work at all. When I clicked on raytrace I got the yellow band at the bottom of the screen and the message that raytracing was starting but nothing happed, no dots that became increasing smaller, only an overexposed image. I used Rhino Renderer and Rhino Next, same result. This was also a problem in 6. The only way that I got a rendered image was by clicking on “render” in the render drop down menu. In that window using the Rhino Renderer I got an image with the scan lines.
As far as the textures are concerned I don’t understand the calculation to apply them to a surface. When they have a directional sense like bricks, they are not applied in the same direction in the same drawing. As an example, if I have house and apply bricks to the walls sometimes they are applied horizontally and sometimes vertically in the same object. Another problem was when I used the UV tool to move the texture there was no texture under the parts of the drawing where I wanted to change the orientation.

Could you please one of each in a zip and share it with me so I can see here what the bug is in Raytraced so I can fix it? You can upload at rhino3d.com/upload?to=nathan@mcneel.com .

Don’t use Rhino Render Next in v7, that is a v6 only thing. in v7 Rhino Render is the better version of Rhino Render Next.

In v6 Rhino Render is still using the old render engine, not Cycles. Hence the scan-lines.

What mapping are you using? Planar? Surface? Box? Custom?

Maybe you can check out the UV mapping tutorial from @BrianJ

edit: forgot the link:

Thank you Nathan, I will upload the file.

Envoyé de mon iPhone

Hello Nathan,
The rendering is worse than ever. When I click render I get a small portion of the viewport, when I click raytrace I get a washed out image that has nothing to do with the image that I see in the Rhino window, the lighting is totally different, what is going on?

Joe

If you could share in a private message here on discourse some screenshots of what you are expected and what you are seeing that would help in understanding what to look for.

As far as I can tell Raytraced in the viewport works just fine.

Hello Nathan,
Here are some screen shots.

Viewport

Beginning of the raytrace

Raytrace after 167 passes

Joe

Hello again,
I have seen the mapping tutorial before. What I experienced was nothing like what you see in the tutorial. After clicking on the mapping icon there was not a texture image only the drawing of the object. I have seen that before but only once or twice in Rhino 6.

Joe

I’ve not used the V7 WIP but is this not something as simple as adjusting the lighting of the scene?

I tried that but doing that is a crap shoot. You have no idea what your lighting will be And it doesn’t work. A similar problem exists in 6. Raytrace renders darker than the viewport. The normal process of Ray tracing that I have seen is that the pixels start dark and get lighter till they are the colors of the textures applied to the model. In 7 there is no change. This has happened in 6 as well. Solution please.
Joe

Envoyé de mon iPhone

Again,
When I use the Rhino Renderer I get the image below.

Joe


This is the rendered image, ugh.

Full image