RayTrace viewport slow in UI manipulation while sampling

For the RayTraced rendering viewport, having the perspective maxed,
the resource seems to be taken up on the sampling of the viewport and
selecting items and such are quite slow.
Having hard time setting up lighting and material

Also need to press “Alt key” to get the pop-ups to show up.
(doesn’t seem to pop up automatically, while view sampling is done)

[7th gen i7 with 24GB laptop and external GTX1070]

One wish is Pause/Play with a macro command for the viewport sampling
or a macro command with Ray Trace <-> None switching.

The macro scripting you already requested earlier, and has been logged as RH-42000

If you want to do larger viewport Raytracing, but it gets heavy you probably can play with the DpiScale setting (which - I just noticed - isn’t being registered properly, so a bit hard to set :° RH-42259 ) to something larger than 1.0 - 2.0 would double the pixel size, exponentially decreasing the amount of pixels to render.

Setting viewport to maximum resolution obviously will need a whole lot more pixels to render.

Until we find a better solution I suppose you should just keep working with smaller viewports, unfortunately :confused:


Thank you for the feedback. I’ll try the floating viewport and resize it down a bit see if that’s any better…

I wonder if anyone else is having this issue…

Thank you for the macro!

Does increasing normal RAM help this case?

I do myself, putting on maximized makes it quite heavy, therefor I use smaller viewports for look-dev (tweaking lighting, materials etc). I haven’t found a good solution yet. And for users with high resolution screens the problem only gets compounded by the fact there are simply more pixels even for ‘small’ viewports… We’ll keep on trying to find improvements.

Note that the macro doesn’t exist yet! A request for it has been logged, but it hasn’t been implemented yet…

1 Like

No problem, as long as it’s coming.

Yeah… I don’t know why they put the 4K into smaller screens… ended up buying external battery for my laptop while on the go…

Wasn’t there a way to limit the use of threading/core to be used for the rendering? I couldn’t find it… maybe it was for Rhino Render…
if some percent of the total resource can be allocated for UI manipulation during sampling of the viewport i that’s possible…