Raytrace Display Render -- Capture To File Not Working?

Not sure if this was ever resolved before the release of V6 – I can capture a raytrace display render to the clipboard but if I want to capture it to a file, it renders in the viewport but the final output is blank.

My recollection is that it rendered blank when trying to render an image sized larger than the viewport.



Hi Jim - as far as I can see this is working. There is a delay - potentially significant - while the view is re-rendered for larger than vp sizes. (2x scale = 4x the pixels etc,)

In fact it is so long, I am no longer sure this is working as it should…


Hi Cal…tried to render a viewport at 3200 x 2400 – yes a long wait while it rendered and then a blank image saved.


This is https://mcneel.myjetbrains.com/youtrack/issue/RH-45147 - it appears to be an OpenGL problem.

Now, there is still a backdoor to getting Raytraced images out through setting in Tools > Options > Advanced the setting SaveDebugImages to true. You’ll find that in your %TEMP% directory you get a file called RC_modal_renderer.png at the end of the rendering process. This contains the render result from the view capture.

Be sure to turn SaveDebugImages off again, because it can slow down the normal operation of a Raytraced viewport. As the name suggests it is a debugging tool (for me really).

Adding this thread to the YT report.

Thanks Nathan!

Hi Nathan, I am loving the Cycles integration and visual results so far have been fantastic so great work! I have been rendering complex outdoor (sun, sky, architecture etc) scenes and have exactly the same problems described by jvm33. I am resorting to screen capturing to get images out which obviously isn’t ideal. FYI the debug file is also blank if this helps you pin point the issue. If you need details of hardware / scene I’m happy to supply. If there are any other workarounds you are aware of in the mean time please share. I’ll keep an eye on the YT status. Niki

@nikischwabe can you share the file with me please? If it is a larger file you can use www.rhino3d.com/upload with nathan@mcneel.com as recipient. Also please provide Help > System Information and the capture settings you’re trying to render at.

@nikischwabe I’ve investigated your model, it is rather big :slight_smile: On my Radeon card it takes around 12GB of RAM. Could you please send me the results of your Help > System Information still?

I think what you get here is probably out of memory effects. If you start the view capture with a target sample count that hasn’t been achieved in the viewport yet the process will essentially duplicate the memory requirements.

In your case, since you’re capturing at viewport size, I’d use the command-line dash version -ViewCaptureToFile or -ViewCaptureToClipboard and ensure that the number of passes is equal or less to what has already been rendered in the viewport.

To find a performance/memory usage optimization solution I have logged RH-45535.

RH-45147 is fixed in the latest Service Release Candidate

A post was split to a new topic: Black in view capture