Raytrace crashing [a simple pushed-about subD box]

I’m getting Repeated crashes with this simple file while trying to change things like skylight setting and material in Raytrace mode
current WIP: Version 7 WIP (7.0.20007.12056, 2020-01-07)

Cycle crashing file .3dm (3.6 MB)
after the crashes this note comes up [I have seen and reported it before but can’t remember where…]

  • I also sent two crash reports.

thanks a lot

I did find any reports in our database. Did you use your e-mail address as you have also on Discourse?

Yes Nathan
it’s automatic nowadays [the email in the crash form] unless there’s an error I didn’t notice… will have to crash again to check this.
Crashing again was immediate, I sent the report the email is correct [same as here]

thanks a lot

@Akash while we wait for the crash reports to (hopefully) appear in our crash database, could you please post the results of the Rhino command _SystemInfo ?


  • I tried with a different file just now, without subD objects.
    it also crashed at the moment I tried to change something in the material, a little strange as I was ok on this file [changing materials] just a couple of days ago…

Thanks a lot

Rhino 7 SR0 2020-1-7 (Public Build, 7.0.20007.12056, Git hash:master @ 9a18142843813da3d13399261d83b0264ea1ddca)
License type: Commercial, build 2020-01-07
License details: Cloud Zoo. In use by: Akash Lotan ()
Expires on: 2020-02-21

Apple Intel 64-bit macOS Version 10.15.2 (Build 19C57) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,3
Machine name: Akash’s MacBook Pro
Language: en-IL (MacOS default)

NVIDIA GeForce GT 750M OpenGL Engine (OpenGL ver:4.1 NVIDIA-14.0.31 355.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB
Graphics: NVIDIA GeForce GT 750M
Displays: Color LCD (221dpi 2x)

Graphics processors
Intel Iris Pro (1536 MB)
NVIDIA GeForce GT 750M (2 GB)
Color LCD (1440 x 900)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
3Dconnexion: SpaceNavigator for Notebooks
Wacom Co.,Ltd.: Wacom Intuos Pro M

Bluetooth devices
Apple: Apple Magic Mouse

Third party kernel extensions
com.3dconnexion.driver (1.1.0) 94E8C49C-EDED-3526-88BE-E7207560C0D2
com.sophos.nke.swi (9.9.4) 1A584D27-3B41-3F92-9D0D-8A30EA3E50F8
com.sophos.kext.oas (9.9.4) 7CED455E-0A13-323E-B39B-FAE664394522

Third party plugins

Rhino plugins
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.0.20007.12056
/Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.0.20007.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.0.20007.12056
/Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.0.20007.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.0.20007.12056
/Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.0.20007.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.0.20007.12056
/Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.0.20007.1002
/Users/akash/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Iris.MacR5.rhp “Iris”
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.0.20007.12056
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.0.20007.12056
/Applications/RhinoWIP.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.0.20007.1002

The same is happening with my machine. I am running an AMD Radeon Pro 5300M if this is of any help…


system_info_amd.txt (2.8 KB)

@Akash the next time the crash reporter pops up, could you copy/paste the crash log from the dialog to me? Feel free to post to me in private message if you don’t feel like sharing that publicly in this thread.

Hi Nathan
here is one
I zipped it because Discourse will not allow .rtf akash Crash report for Nathan to look at.zip (43.5 KB)
thanks a lot
Steps taken: 1) open the previously uploaded here file.
2) select materials tab.
3) press the + Botton to try and change material.
4) rhino crash.
it the same thing if I go to render lights and try to change something, so it is not specific to Materials tab.
thanks a lot

Thank you for the material, @Akash! Looking into it now.

Edit: this looks like a crash in the GPU driver when a shader for the display of geometry is being compiled. I’ll have to ask @jeff and @stevebaer if they can spare some brain cycles. I hope they crash log you provided can give them more insight in what might be the issue here..

Edit2: Oops, I’m being to fast jumping to conclusions. The crash is not in the driver itself, a different thread crashes. Investigation continues - sorry for the noise :]

Hi Nathan
just to note that the Crash is constant also in today’s WIP
akash Crash report for Nathan to look Latest WIP 15Jan2020.zip (48.1 KB)

  • I think this was requested in the past by someone… to make it so that a file will not re-open in Raytrace mode [especilay after it crashes]. I feel wireframe or shaded should be the revert default for reopening a file.

thanks a lot

Hi @Akash,

Yes, no doubt the crash is still happening - I have been investigating a lot and the work is still continuing.

Until loading with a non-realtime display mode integration is done you can import the 3dm into a new one.