Random Script crashes in Rhino 6 SR6 latest RC


#1

Since installing latest SR6 RC some of our scripts are randomly crashing Rhino (both ran from RhinoScript Editor and as compiled plugins). So far sometimes it works fine, sometimes crashes the program completely.
I have sent several crash reports, but wondering if anything changes in that areas since last SR that could affect that. The scripts worked fine before SR6 and in Rhino 5.

–jarek


Make2D - Crashes Rhino 6
(Jeff Lasor) #2

@Jarek

What is the exact version of 6.6 you have? I recently fixed something very similar in the 6.6 branch… I will look to see exactly which version that fix made it into…so I’d like to know what yours is.

Thanks,
-Jeff


#3

hi Jeff,

thanks, my version is:
Version 6 SR6 | (6.6.18149.11011, 5/29/2018)

keep in mind that all worked just fine right before this one was installed…


#5

nope; 404 error…


(Jeff Lasor) #6

Ok thanks… The fix is in 6.6.18152


(Jeff Lasor) #7

Ok…give me a minute or so… I’ll get the right link.

-J


(Jeff Lasor) #8

Try this one: http://files.mcneel.com/dujour/exe/20180601/rhino_en-us_6.6.18152.00001.exe

-J


(Jeff Lasor) #9

@Jarek,

Assuming that latest link works and installs… Please let me know if you’re still seeing the problem…since this is considered “breakage”, we need to get this fixed in 6.6 asap…unless the fix is already in there.

Thanks,
-Jeff


#10

Hi Jeff - testing for the past 10 minnutes on various files and settings no crash so far.
Before it would crash very often (randomly).
So for now let’s assume that fixes it :slight_smile:

Thanks for your prompt help!

–jarek


(Jeff Lasor) #11

:+1: