Radius and Diameter dimensions for objects inside blocks

Hey guys,

I’m trying to use the radius and diameter tools to dimension circular surfaces, but it is not letting me pick the edge to use of my surface for the dimension.

My object is in model space and I am dimensioning in layout space.

The issue is caused by my object being inside a block. If i explode the block I am able to dimension it correctly. However the whole reason for me using a block is that the item is used multiple times within my model - if I explode the block, then each time I want to change that part, I have to update multiple objects, rather than updating only one and the block definition taking care of the rest.

Is there any plan to allow dimensioning of circular objects within blocks with the radius & diameter tools in the near future?


I think this is on the list for V6.

Hi Iain - as far as I can see, what you describe is true of the circle is in a nested block and not if it is at the top level of the block - does that correspond with what you are seeing?



No, quite accurate. My block is a simple block with only one object in it, and it is not nested.

I am trying to dimension in layout space. If i double click through to model space, the dimensioning tool works properly, except my dimension is now in model space :confused:

I just tried it in an in-house build of V6 and it works correctly in a layout, even with blocks with multiple nesting levels, that is blocks made up of other blocks.


For now i’ll stick to a leader with the dimension written in it…

Just to add a little confusion to the mix, I just found that I could dimension some circular objects but not others :confused:.

After a little more digging, I think I’ve figured out this out though - if you have an object’s layer turned on in a detail view (layoutvisible = on), but that same layer is turned off in the layout (layoutvisible = off), then the object is visible in the detail view but I cannot dimension to it. If I then turn the layer on in the layout (i.e layoutvisible = on in both the layout and the detail view), I can then dimension to the surface edge I wanted to.

Not sure if you file this under /bug or /userisdumb, but to me if I can see the object in a detail, I should be able to dimension a radius/diameter on it (especially if the other snaps for linear dimensions are working…)


Just to make matters a little weirder, after all that I had one object that would still not dimension the hole in it. I edited the block, and exploded the object (closed extrusion) and rejoined everything (now a polysurface). Now I could dimension the hole in it. Maybe something to investigate with closed extrusions vs polysurfaces inside blocks?


Yeah - this makes some sense as far as I can see - the layout cannot ‘see’ the layer but the detail can. Both are visible at the same time so the layer is drawn in the detail — I guess that can be confusing but I do not see a way out, myself.


Yes its a tricky one. The logic is correct but creates an odd situation in this example.

The way it is handled in AutoCAD is to have 3 sets of layer visibility settings for each layer - on for model space, one for model space inside viewport/detail views, and one for pure paperspace.

With Rhino, the detail view on/off setting is used to control visibility in both the paperspace and the detail view, which is where the confusion arises.

I’m not suggesting that you re-write the whole code to mimic AutoCAD’s method, but maybe some way of warning the user that they may not be able to snap to visible objects?

Another thought I just had is why not have separate sets of layers for model space and paper space - it is unlikely that people need all the same model layers in paper space - typically just layers to put the border, title block, text and annotations on.

I find this also a problem with any hole in polysurface object. I have a simple square hollow section tube with a small hole in one face and a larger hole in the opposite face set on the same centre line.

In detail view on a layout I just canot dimenion the diameter or radius of the holes in the layout. The polysurface in my case is not a block. If I double click on the detail I can add diameter and radius but it does not appear on the layout sheet. This is VERY intermittent as I have layouts with four or five detail frames showing various aspects of my model and some allow me to dimension diameters and radiusses in the layout sheet and others don’t. In the case described above I have been unable to dimensions it since it was first created the model so I measured the dimameter by double clicking on the detail view and then used a leader to type in the dimension and cented it on the hole using object snap set with point and centre enabled. in the same model I have layouts where the diameter and radius work fine on holes so it does seem to be an going bug given the last rely to this post thread was 4 years ago !!

Hello - can you post a file with the object and a layout where you see the problem?


Its 590 MB model so I cannot realy post it.
I have got a work around though. If I create a new layout sheet, then go into the one that is giving me issues and press [Ctrl A] then select the new layout sheet and press [Ctrl V] to copy all the details panels and layout text, and dimensions to the new layout sheet. I can then add diameter and radius dimensions to the detail panels of the parts of the model that would not work before. I then delete the the old layout sheet and rename the new one to the orignal sheet reference.
Not sure why this works and it a bit laborious but at least I can get on.

Hello - if you can reproduce with just some of the objects, post a file with those, otherwise, if you can
SaveSmall and zip your file and post to


with a link back to this thread, we’ll take a look.