Question on RH6 usability, again

I have an oncoming presentation to make and…

  1. I can’t render high-res images on Cycles. Recently it gave up doing even screen resolution - sized pictures bringing grey image only as an output.
  2. The pdf printer is displaying me message: the given key was not present in the dictionary.
  3. The Microsoft pdf printer is printing files with no content and 0 kb.
  4. The Mac version is printing files with solid background unable to remove even in Illustrator.
    How I am supposed to work?

I need to undust my 10 years old laptop with Rh5 that never failed to do it’s job. I don’t give a … it was working longer. It Always did the job and that’s what’s matter to me and what I expect from Rh6.

I’m frustrated. I don’t want to hear 'What your machine and what’s your setting and all bla bla*. I have Rhino 5 running on ca. 15 years old laptop with XP which I use sometimes because my 3.5k GBP laptop is, somehow, no good for Rh6.

So what you wanna hear?
What’s the question?

RH-45147. As a workaround you can set the advanced option RhinoCycles.SaveDebugImages to true. When you then use the view capture commands you’ll find at the end of the process in %TEMP% a file called RC_modal_renderer.png is created. This is the result of the Raytraced view capture. The blank renders you see are due to an OpenGL problem which is being investigated and fixed. The hacky workaround should give you the Raytraced results you are looking for. Remember to turn it off after a view capture, as it will also write out intermediate results and textures for a regular Raytraced view - it can be a slowing factor.

Are you running 6.3? I fixed some PDF issues in SR3.

I am using lates SR4 Candidate. It also appears in WiP.

Hi Nathan.
I have been waiting with respond to confirm that method you advised works.
After 10 failed attempts to render and changing the settings I have made 2 successful renders to the file with destination I created, no need to dig in TEMP folder. (?)
Don’t know what to say except I’m happy that the job is complete.
Please have an extra look to this issue. Creating large images is essential.
PS. I’ve tried to bypass the problem by changing the render engine from CPU to GPU (Radeon 55something) but it was 3 times slower and it made rhino stop working when Windows when into sleep mode (it doesn’t happen when CPU option is ON).
Thanks for your assistance.

The problem is related to some OpenGL error and will be fixed eventually. The workaround I gave is for you to use without having to rerender and try multiple times until the bug is fixed.

In my own tests both CPU and GPU work fine, at least the Raytraced part. Anyway, keep following the YouTrack item I linked.

I would love to see a model where the PDF printing bug occurs. If I can repeat this “given key was not present in the dictionary” error, I should be able to fix it pretty quick. I know you sent a file in the past, but I was never able to repeat the bug with that one. More than happy to give it another try if you have a different model.

The file itself is as simple as it can only be.
PDF print test file.3dm (88 KB)
This files comes from Mac version but I’ve tried to print it from RH6 to have a clear background.
Hint: could the problem be due to öäå (Swedish) letters?

FWIW, I have no problems when printing this file on my system…

As an update, I can repeat this bug and it looks like it is has something to do with the font being used. We license a toolkit for generating the PDF file and have contacted the author to get some help. Hopefully we’ll have a fix for this soon.

I’ve added this to our bug tracking system at

This is because you don’t have the font installed that is causing a problem (MyriadPro Light Cond). When the font doesn’t exist, Rhino finds a fall back font to use instead.

Myriad font family is common and widely used. Are there any other fonts that cause this problem?

I don’t think it will be a problem. It’s probably “just a bug” that we need to fix.

RH-45147 is fixed in the latest Service Release Candidate