QuadRemesh R7 SR13 RC Windows (7.13.21313)

QuadRemesh: Updated to a new versions (RH-65907 )
Triangles are not 100% avoided, edge detection not allways good.
Adaptive size 0%
AS0
Adaptive size 100%
AS100

Option “Use Surface Edges” are broken or unclear ?
OE
Set option to “Smart” Rhino says "Select Quad Mesh options !
Same with option “Strict”
Unselect “Preview” command line shows command as finished but QuadRemesh window is on top and active.

So, downgraded to “SR 7.12 Stable” and quad remeshing is more stable.
Option “Use Surface Edges” are worked here, but the feedback on command line needs fine tuning.
Thanks and regards

Hi Eddi - can you post a file where 7.12 works differently from 7.13?

-Pascal

Hello @pascal
This small testobject was exported from 7.13 build
truncated cone + sphere + boolean union
Reimport back into build 7.13 not tested, but reimport in build 7.12 SR was worked.
AS_0_100.3dm (141.6 KB)

Hi eddi - I am still messing with this but in oor latest I get pretty clean results if I specify curves like so The marked edges) :

The same settings, I think, in SR 12 gets me some triangles

And SR13 does not get me any triangles - however, it does seem to depend on the curve selection process - possibly the order - somehow, as well, so I am not sure they are different.

And yes, the surface edges setting seems at least damaged, or broken…

RH-66283 QuadRemesh: Surface edges

-Pascal

Hello Pascal,
thanks for the investigation.

in full automatic mode, option Smart, Strict, here it was not stable.

So I thought.

The quadremesh (with no options) does not work on this subD object (Rhino 7.12).
Errore quadremesh.3dm (488.5 KB)

Supplementary, option “Use Surface Edges” not selectable on SudD objects, latest used option is set

Inner pipe is doubled in the file.

Like in many other cases, quadremesher gives better results if you convert the original subd or Polysurface to a good mesh first.

3 Likes

I tried.
If I convert that SubD tube to a Nurbs, and then run the quadremesh, this works.
(strange that it gives problems from a SubD to quadremesh).

In my opinion it’s a bug: it doesn’t make sense to have to switch to a mesh, otherwise it shouldn’t work from Nurbs to quadremesh

@davide76

More simple here, no need QuadRemesh, this quadlayout ist clean, so we can use
Option “Custom Mesh”, then “Adjust” with slider to lowest level, then _ExtractRenderMesh, then _Weld (40)

1 Like

RH-66283 is fixed in Rhino 7 Service Release 13 Release Candidate