Quadremesh gets some weird stretches

Here’s my setting,

No, I tried both strict and smart.

I used to thought “strict” means no stretch, now I know I’m totally wrong…

your initial mesh may be defect. somebody can sure tell you more if you post a portion of your file.

Thank you. It’s not a mesh, I quadremesh nurb surface directly.
stretched mesh.3dm (4.1 MB)

please extract a detail of the file, that concern you most - or is related to the initial screenshot
this is not a

kind regards -tom

in that case it is your polysurface which is a good mess. i am not fully sure what is going on also be aware that you have open edges and open surfaces. the surfaces are barely planar.

i got quadremesh to behave a bit better with these settings, strict smart no difference. the main factor seems to be increasing the target quad count. dont overdue it might deteriorate again.

1 Like

stretched mesh.3dm (12.4 MB)

Like this, it stretch wildly by the opening. the weird opening is because I offsetsrf then pick random surface as a group.

Will try this setting, still curious how do you prevent it from stretching?

@DanielPiker i might have helped out here but it still looks a bit odd, to fiddle that hard with the settings does not seem right, maybe you want to have a look. i assume it could be the variety of widths between the windows? so practically you have to get the sequence right by which all the dimension can be divided… i am just wildly guessing.

Thanks for your help! I will definitely try that when time allows.