Pydev for external debugging

Hi,

I dont’ want to post this in the original topic, which can be found here:

I set up everything like mentioned in these topics I’ve found:

But unfortunately I don’t get the external debugger running. When I start the debug server in eclipse and run the same script in _runpythonscript, eclipse doesn’t get information for debuging and rhino freezes.

I attach all the pictures of my preferences. I tried it with the ipy64.exe as well with the ipy.exe. Always the same problem.

System:
Windows 7 64 Bit
Rhino5 64 Bit
Eclipse IDE for Java Developers
Version: Luna Service Release 1 (4.4.1)
Build id: 20140925-1800

Thank you.




Hi ZweiP,
Remote debugging is something we are working to support in the future but right now even though some have been able to make it work it’s not easy and doesn’t always work. In some cases in addition to checking “Frames Enabled” in the “Script Engine” tab of the Python Options, Tracing also needs to be enabled. Tracing can’t be enabled in the Rhino 5 version of IronPython but will be in Rhino 6.
One thing you can check. Under the Python Options dialog under Module Search Paths I can’t see the whole path in your screen shot. Can you confirm that the directory org.python.pydev_3.9… contains the subdirectory pysrc that contains the file pydevd.py?

Hi @Alain,

Thank you so much for your reply.
First of all the Frames Enabled Checkbos is marked.
And under the Module Search Path the subdirectory pysrc is loaded.

I debugged the script in Rhino without the settrace command. Everything looks fine. The pydevd is imported and there is no ImportError.

try:
import pydevd
except ImportError:
print(‘Error You must add org.python.pydev.debug.pysrc to your PYTHONPATH.’)

I also tried to debug it in eclipse and even there everything looks fine. It even breaks right after the settrace command. I really double checked everything.

But there must be something wrong with the settrace command. Right after compiling the settrace command eclipse recognize that there is something comming in (debug server --> unkown), but then rhino chrashes with no reply.

What else coud I do to make it work?
Thanks

best regards
ZweiP

Hi ZweiP,
If you followed the instructions from the different links you posted above and it doesn’t work then I’m not sure what else you can do. Even though some of us managed to get it to work some of the time it’s not reliable. We’re working on making this better in Rhino 6.

@Alain

Thanks for your help. I tried so many things (reinstall, different settings …), but I couldn’t get it work. Now I give it up for a while. It would be great if it is possible to make some “normal” Python (numpy, scipy …) not IronPython scripts work on Rhino 6. Then it wouldn’t be necessary for me to have an external IDE.

When is Rhino 6 going to be released?

Thanks ZweiP