Publishing a PDF file


I have been using Rhino 6, and trying to create a PDF file of 2D drawings. I have clicked on the upside-down triangle next to Page 3, in order to let the print setup box appear, as the attached image shows. However, the box has shown no 2D drawings but it has shown a black box, as the attached image shows. I was just wondering how this problem could be solved.

Thank you.

Please assign your new messages to the appropriate category so the right people see it.


1 Like

The Microsoft print to PDF printer should be avoided. It’s all but useless for anything other than Letter size text printing.

The Rhino PDF printer is much better.
I also like the free PDF995 and BullZIP Windows “Printer” drivers.

See if one of those works better.

There are other possibilities for the problem so please report back.

Thank you very much for replying.
I have changed the printer to Rhino PDF, but the same problem has remained, as the attached image shows.
I have just found that if I change “Layout” to “Extents” under “View and Output Scale”,
the black box will just become white.

The problem has not been solved, unfortunately.

Okay, that is informative.
Printing and display are tightly coupled.

How many monitors are you using?
Is this a desktop or a laptop?
If a laptop, how is the extra monitor connected?

Please replay back with that information and also run the Rhino “SystemInfo” command and include that too.

That should point a way forward.

This page has helped.

Thank you.

Hi -

That’s good to hear, of course. I’m not sure what on that page did the trick but I noticed from your SystemInfo that you are running Rhino 6 SR21 from December 2019. Please update to the current 6.34 release.