Project Toggle Without Toggling Copy?

In Rhino, I have a keyboard shortcut to toggle the project osnap:

    _ProjectOSnap T

However, it always flips the toggle for copy on a command. Anyone know why/how to fix this?

Not in front of my rhino, but I think if you leave off the “T”, it will work as you want… – Mitch

Hi Eric- so the “/_Copy” is showing up on the command line on its own when you use T for Toggle? Is T an alias in your setup for something by itself?


OK, now back in front of my Rhino I see that you do indeed need the toggle part, I have it spelled out in my keyboard shortcut…

'_ProjectOsnap _Toggle

That doesn’t trigger any copy option here, so Pascal is probably onto something -do you have another alisa somewhere that might be triggered by “T”?


This is all I have set:

“_ProjectOsnap T”

The question is whether you have an entry under aliases that binds the letter T to some other command.

Also, does it work if you write toggle instead of just T?

T is not an alias for anything and no hotkeys are tied to “/_Copy”. It just shows up on it’s own. I tried Mitch’s version with the same results:

    '_ProjectOsnap _Toggle

This has bothered me for a long time. Now that I’m looking into it, it gets stranger. It only inserts the “/_Copy” bit when the command presents “(Copy=Yes/No)” as an option. Any other time it doesn’t happen.

This also occurs with my “_Between” hotkey. That combo flips the copy bit, but only if its available.

My space mouse is also part of the problem. If I manually type ctrl+alt+3, everything works as expected. But calling it from the space mouse:

It inserts the “/_Copy”.

I hate using the 3dconnexion macro editor, so I wired every button to a ctrl-alt combo and then in each application I manage what it really points to. Still weird though. Nothing in the space mouse points to anything other than a ctrl+alt command and none of the ctrl-alt keyboard shortcuts in rhino point to /_Copy.