Project text on SUBD

Hello guys, I’m trying to prject a text on a very complex subD “I think around 2k faces”, do you know a way ?

Hi Zifo - are you projecting text-shaped curves, or actual text objects? What happens when you try? Text will not project but of you explode it the resulting curves ought to.


Hi Pascal, if i try i just get curves on the sub d, but i actually need the 3d Text on it

a workaround is,
copy the subd, convert to nurbs, then use flowalongsrf on the nurbs copy.

then delete the nurbs copy

1 Like

I am working on updating a ProjectObjects script to accept SubDs as targets… - you can try this plug-in -
ProjectObjects.rhp (24 KB)

Un-block the rhp file in Windows and then drag and drop onto an open Rhino window to load it - the command is ProjectObjects



Hello pascal, thank you a lot, i don’t know if i installed the plug in correctly, but if i did unfortunately it doesn’t work for this.

(That’s what i see after i unblock the plug in and drag in)

A variation on what Kyle suggested is to use DupEdge to make curves from the even quad faces you have in that area and then use NetworkSrf to model a single NURBS surface there. FlowAlongSrf to that surface after.
You can open up _PluginManager, and look for the plugin to see where it is located, by double clicking or clicking on details. Then close Rhino and replace the file, and restart Rhino

I was [not sure why…] imagining, that I remembered, that dropping an .rhp into rhino now [in the WIP] also work on Mac [but my old computer with the latest WIP keep asking if to open/insert, or import…
Am I missing something here? or is .rhp still beyond the Mac realm?

thanks a lot

Hi Zifo - what happens if you run the command - ProjectObjects?


1 Like

Hello Pascala, sorry if I reply so late but i was abroad, anyway I’ve checked and the plug in it’s installed correctly into rhino.

But still it doesn’t work, actually when I run “Project Obkect” and do the process nothing happen… maybe I should go for another way, what do you think?

Hi Zifo - yeah, I see I broke something - hold on a bit, I’ll see if I can figure that out. - I replaced the plug-in above - that one works, here.


1 Like

Hello Pascal, sorry for the delay, I’ve tried again the plug in but it still doesn’t work on a SUBD, now I show you the steps I’ve made:

Actually what I get it’s a double polysurface.

Hi Zifo - OK I’ll fix it… can you please send your file to to my attention? Or you can post it here, but that will be public.

@Zifo - the projection direction is Cplane Z by default - like the Project command. You can either set a new cplane to the plane of the text or use the user set projection direction.

(however, it should no leave a copy in place on failure - I’ll fix that)


1 Like