Problems withFillet Surface Tool

So again I have a problem with a tool, which I think is eventually more of a general problem of not understanding how to model with Rhino.

I got this setup which is basically one surface belt (yellow), which is joined out of 10 smaller surfaces (red) and one planar surface, which is trimmed on the outside and trimmed on the inside by the curves of the 10 smaller surface.

Now I want to do a small fillet all the way around. But when it tells me to select the surfaces it recognizes the planar surface as one and the belt as as seperated surfaces, which ends in a failed fillet.

So my question is: How do I model this properly to be able to fillet this all the way around?

Fillet.3dm (195.4 KB)

Hello - the fillets do not fail - they are created, right? You can work your way around making individual surface fillets,and trim them in after, or join everything and FilletEdge (use the ChainEdges option) to do them all at once and trim and join. Note one surface needs to be untrimmed (UntrimBorder) and joined in for this to work. A possible advantage to using FilletEdge is that you can set the rail type to ‘DistanceBetweenEdges’ and get a more visually consistent fillet than a Rolling ball one. In this case the angle is pretty consistent so it may not matter much.

I’d set the file tolerance to .001 here, btw.


Thanks for the reply.
The fillets are created, yes.
FilletEdge works perfectly :slight_smile: I didn’t know this tool. Thank you!

In rendered view I cann still see some gaps. Are they real or just some tesselation problem?

Hello- does the object show any naked edges (ShowEdges command > Naked edges) Also, if you did not, I would Undo the fillets and do them again after setting the file tolerance to .001.


No, there are no naked edges. So it should be fine, I guess?

I think so - you can clean up the display by setting custom meshing in DocumentProperties > mesh page and set ‘Minimum initial grid quads’ to say 32


1 Like

Yes, i am happy with that. Thank you so much for the help!