Problems with WIP

I apologize if this issue has come up already, or if this is the wrong thread…

I work in Architecture field and these are some of the critical issues which I wish you can fix…

  1. The compatibility between different versions of Rhino seem to be unstable.
    -The office had different versions of Rhino (4 &5) and whenever I opened up a Rhino 4 file in V5, the surfaces would kind of dislocate, and the objects which were meant to be on the same coordinates would wind up (ever so slightly) detached. It was also difficult to ‘snap’ onto these objects’ endpoints as they became dislocated. And sometimes there were surface errors.

  2. I use the loft function a lot, and in situations where the curvature is extreme, I end up with inaccurate surfaces.
    I have watched modelling tutorials provided by McNeel site to improve my approach. However, sometimes, the software just could not handle the curvature. Depending on plug-ins like T-spline (or plugins in grasshopper) helped a lot with this issue, but I wondered if this can be improved within the Rhino software itself.

Thank you!

Hi Taeyoon - are the objects very far from the World origin?

It would be useful to have an example of this - there is almost certainly an alternate modeling procedure, but it’s hard to say without an example.


Sorry for the late response…
No the objects were not far away from the world origin.
I do not have screen captures from the previous file, but I have upgraded to V6 completely, and noticed similar issues with display.

When I zoom into polylines, the points become somehow dislocated…? So if they were snapped to an identical point, when I zoom in, they are displayed apart.

I also noticed that in V6, The LinetypeScale is not displaying correctly below 0.5 - The same object displays properly in V5.


And this is the linetypescale issue;
(Dashed line displays correctly in V5)

Like before, when I opened a V4 file in V5, Those end points, where objects are snapped to, would all be dislocated, but ever so slightly… So performing boolean operations and other boundary-sensitive tasks on the model became very messy.

I would also try turning off GPU Tessellation (Options -> View -> OpenGL) to see if that helps, as curves can get sloppy with this on.