Problems with shadows in shaded view and help with settings for my GPU

  1. I am having some trouble getting controll over my shadows in Shaded view. I have turned on the Shadows in the display mode and if i try Raytraced I can see the shadows. Not sure why

Would also like some tips making the most out of my nvidia P1000 4GB card. Here are the specific to Rhino

in the Nvidia control panel :

would really appreciate some tips on what settings to fiddle with.