Problems with OffsetSrf


#1

(See below for picture)

I have the following two problems with OffsetSrf:

  • I’ve found that with my object, I have to explode it into pieces and offset small groups or individual pieces. I also find that choosing the order makes a difference as on a couple of cases the command has not worked properly and I get open ends or I get totally erroneous results;

  • I end up with a large number of isocurves.

I have upgraded to the latest version of software, but is there any known bug or ‘personality’ with this command that I should be aware of

Up to now I have been creating the object with walls of zero thickness. I’ve added each branch by merging a newly created branch with the existing structure, trimming off the unwanted portions (including the internal pieces as I want the whole structure to be hollow) and then filleting the join. I was intending to wait until the very end before using OffsetSrf to give the walls a thickness.

Questions:

  • is there a way to reduce the number of isocurves after OffsetSrf? Rebuild doesn’t work. The only option seems to be to explode the whole thing, select the pieces that have the large number of isocurves, rebuild those pieces and somehow re-join everything;

  • is my abovementioned process okay, or should I add thickness as I go?

The following picture shows my model after having used OffsetCrv (doing it piece by piece).


#2

Actually, I take that back. Exploding and rebuilding the outsides doesn’t work as then the pieces such as the end caps no longer fit.


#3

Well you are working on a pretty organic shape there, none of that is suprising. Are you trying to offset “in” or “out?” Why specifically do you need to reduce the knot count on the output? It’s fitted to your file tolerance, so loosening tolerances will help but you don’t necessarily want to do that.


#4

I’m offsetting out. I’m trying to reduce the knot count because I thought that that was best practice. Also, it gets very difficult to see what is going on with so many lines. I’ve no where near finished the model.

I’ll try loosening model tolerances.


#5

It would probably work better to be offsetting (or shelling) in especially if you’ve got small fillets between the branches there that are guaranteed to turn inside-out trying to offset out.

It is “best practice” to make your surfaces as simple as possible but if you’re relying on OffsetSrf to produce your outer surfaces that just doesn’t really apply, you can’t touch it without breaking something, and it’s not like you’re going to(well you better not be planning to)do a bunch of point editing to these. As long as it’s not folding on itself or otherwise mangled, it’s alright. Again, for that reason it’s best to keep the offset to the inside. If the isocurves are getting distracting and slowing down your display they can be turned off in the object properties panel.


#6

Thanks for your help. I’m finding that changing the tolerance is working fine. For the future branches I’m also going to add thickness as I go and fillet after adding thickness, not before.


#7

Well you have to watch that you haven’t set your tolerances too loose for your downstream applications.