Problems with custom hot keys


#1

I have some custom hot keys setup that are giving me some problems. When I run a command like extrude one of the options is hitting the “b” key for both sides but instead it runs my hotkey associated with the “b” key.

I also have a hot key setup for the “1” key and anytime I start to type a value starting with a “1” during a command it runs my “1” hotkey. Is this a bug or is there a way disable hotkeys during commands?

Thanks,

-Shane


#2

i thought i remembered that not happening before but i suppose i thought wrong…

i just tried setting something to “B” as a shortcut and yeah, trying to push b during a command attempts to trigger the keystroke again…

fwiw, if you push shift-B for both sides, while having a keystroke set to B, it will work as expected.

that said, i personally think you’re better off not using single key shortcuts in rhino… maybe change your “B” and “1” keystrokes to shift-B and shift-1 instead and let the single key stuff remain open for use in the command dialogs.

or, if your finger gymnastics aren’t up to par yet, make them aliases instead (Rhinoceros-> Preferences-> Aliases)… so it’s “B” followed by the spacebar to trigger the command you have assigned to it.

(just ideas-- maybe it’s worth making it so you can have “B” as a shortcut and still be able to use it in command dialogs? not up to me though)


#3

Hey Jeff you are correct this is new behavior.

I personally prefer the single key and use them in most of my apps as I think hitting enter is a bit clunky. If this is something that is intentional or can’t be fixed using shift+hokey or another combo would be a possible workaround.

I use a bunch of programs that have common commands and I try to keep the hotkeys the same to help speed-up my workflow and save brain power.


#4

use the spacebar instead of return… especially with a letter like B
you can literally push B then spacebar in one motion…

(for clarity- i’m not trying to talk you out of what you want… i understand what you want and don’t think it’s stupid or whatever… just offering alternative ideas is all :wink: )


#5

The fact of the matter is that single key “hotkeys” do not work in programs that have a command line like Rhino. Rhino can’t tell the difference between you typing the key as a hotkey or typing the beginning of a command that begins with that same letter. Also, single letters are interpreted as options when you’re inside of a command.

Thus, single letters/numbers are to be avoided as keyboard shortcuts.

–Mitch


#6

Thanks Jeff, I understand you are just trying to help. I do use the space bar in most situations. I meant “return” as another keystroke wether it is spacebar, right mouse button, or return key. It is just an extra step.


#7

Hey Mitch, it use to work just fine with single hotkeys. Something seems to have changed in the last few builds. If a command dialog is in progress I feel it should get the keyboards attention. You are correct about typing a command. When I type a command I use a hotkey to invoke the command dialogue and then type my command.

-Shane


#8

Well that may be due to the particular way the command line is implemented in MacRhino, but it certainly doesn’t work in Windows Rhino where the command line is “always-on”.

–Mitch


(Marlin Prowell) #9

Yes, this is a bug. Rhino needs to pay attention to whether a command is running or not when deciding to consider typed characters to be menu shortcuts or not. This will be fixed in the next WIP release.


#10

Great news, thanks Marlin.

-Shane