Problems filleting object edges (created from CreateSolid cmd)

I successfully created a solid using the CreateSolid cmd, however now I am having errors filleting the edges. I used the FilletEdge cmd. Either one surface disappears, or the surfaces get extended in weird ways:

The object looked this before I tried to fillet:

Any thoughts?

Have run the _ShowEdges command to make sure the solid is fully closed?

I have run ShowEdges, and it appears that the solid is closed - I made sure the surfaces were all overlapping before I ran the CreateSolid cmd.

Welp, as someone else on here (?) suggested, you could always try exporting a STEP file to Fusion 360 and trying your filleting there…

Not quite sure what you meant by that (I don’t know what Welp means), but I do not want to hop around between different 3D design applications, I want to stick to Rhino. I tried it again, and it worked a short time ago, but when I undo it, make adjustments to the surfaces, then try it again, it fails. Does anybody else find that Rhino is a bit unreliable in trying to perform commands on shapes?

Could you maybe post the .3dm file with the object in question?

‘Welp’ is like when you shrug your shoulders cos there’s no solution.
Fusion doesn’t always work either, but it seems to be far ahead atm, and free to a small-fry like me so…
Fillets have been an issue in Rhino since the beginning, and improving them would be my number-one favorite improvement.

Thanks - I’ve now managed to fillet most of the edges one-by-one, gradually increasing the angle slightly using the EditFilletEdge cmd, and all work except the very last edge. So the error seems to relate to applying a certain angle setting (4) to a specific handle to a specific surface…

It might stem from a problem specific to my shape on certain surfaces, so I may have to try working it from scratch after adjusting one of the surfaces, to see if it works properly.

Will keep you all posted when it works for sure - unfortunately I can’t post the .3dm file as it’s a real life product development so it’s a bit secret :confused:

Without seeing the file in question, it’s difficult to tell but you should use FilletSrf instead when FilletEdge is failing because it’s way more robust and although it is a bit more labour intensive with FilletSrf (set to trim=no, Extend=no) you can practically solve all fillet situations.
Btw your surfaces look also way to complex for the shape you are building and this could also be a source of your problem.
One other thing to check for is that the FilletEdge doesn’t run over surfaces that would fully consume a surface as this won’t work in Rhino. Furthermore the minimum radius of your surfaces should all be larger than your max fillet radius.

Well FilletSrf is obviously not more labor intensive because you could be done in minutes instead of it taking days.

The first mistake the OP is making is to turn this into a solid and then try to make fillets. That is doing it backwards. Leave the surfaces untrimmed and then make fillets and then trim and join.

The easy steps to doing this correctly would be to leave all 6 surfaces untrimmed. And Then:

  1. make the 4 vertical fillets using the extend=yes and trim=yes
  2. then using a slightly smaller fillet size make the eight fillets on top and bottom using extend=no trim =no option.
  3. then trim the 4 vertical fillets with the fillets that wrap around them
  4. then join all the fillets and select the joined result and trim the 6 base surfaces.
  5. then join everything into a solid

It would be very easy to automate this process. Especially step 2.
Making the eight fillets in step 2 should only take 2 clicks of the mouse (instead of 16)

McNeel stubbornly refuses to make improvements to Rhino’s surface modeling tools and instead wastes enormous amounts of development time on solid modeling tools that rarely work any better than the did 20 years ago.

You don’t need solid modelling tools to make good solid models. In fact the Rhino solid modeling tools make lousy solid models. If you want good solid models use the surface modeling tools.

Thanks a lot for this - I am giving it a try today, will let you know how I get on…

The surfaces are not that complex - they were built with line curves using one of the surface commands, so I don’t see how it can be troublesome building a 6-sided shell.

Update: Ok, I tried it and I really appreciate the help you all have given me, and I managed to get the 4 main fillets around the sides of the Shell done, but fail when I try to the top and bottom fillets. To be honest, as an inventor/innovator, it’s very frustrating knowing exactly what I want to achieve and how I want it to look, but being held back for days by unwieldy/unreliable computer programs. I’ve uploaded the file and would really appreciate it if somebody could just do it for me please, as you all know a huge amount about Rhino, whereas I don’t have time to waste days trying to achieve this and getting nowhere. Willing to pay if necessary. I just need the top and bottom fillets being put in place, top fillet is 2.5 all around the top, bottom is 10 all around the bottom, and I would like the result to be trimmed/split please to look like a curvy 6-sided box.
Shellv1 002.3dm (1013.3 KB)

You didn’t use the extend and trim option set to yes when making the 4 vertical fillets. That makes it a lot easier to make the rest of the fillets.

In the enclosed file I made the top and bottom fillets with radius of 70.

I also did it a second time with the surfaces rebuilt to 10 points and the file tolerance set to .01 mm which is a reasonable tolerance for something this large. You probably could simplify these surfaces even more.

Shellvx.3dm (2.0 MB)

I finally got it to work - thanks a lot: