Problem with units, tolerances, moving objects


#1

Hi there.

I am having a big problem with the units in my Rhino 4.
The problem has suddenly come.

Here is what happens:
Start Rhino 4 i my Windows 8.1.

Draw a cube, enter height e.g. 3.5. Works as expected.

As soon as I open any dialog like open, save as, export, etc. something gets broken. Let’s say I type “open” and immediately close the dialog without doing anything.

From that point on, Rhino ignores anything behind the period.

If I draw a cube with height “3.5” it will be “3” in height.

I have read that…

"the problem is caused by the Windows Vista/7/8 style open/save dialogs. As soon as you open one (doesn’t matter if you export, import, save as, etc.) Rhino gets broken. The command TestToggleFileDialog (hidden command) changes the dialog style to the old “XP style” which works correctly.
Just put it in the “Run these commands when rhino starts” box in the General tab of Rhino options and youre problem will be solved.
This happens in Rhino5 32bit only and not on every installation, so you only need it if you have the problem.***

My problem that this solotion doesn’t work in Rhino 4. When I open Rhino it says “Unknown command: TestToggleFileDialog” in the Command line.

I really really hope that someone can help me…


#2

What happens is that all decimal places are ignored in all input boxes. The strange thing is that then there is commas as decimal separators in the input boxes, they should be dots. I’ve never seen commas in these dialogs…
Please see the screenshot.


#3


#4

Your system is set to danish locale and normally uses a comma as decimal separator. Your installation of Rhino uses english locale. While this works in general, it may be a cause for locale conflicts.

When Rhino displays the file dialog, the system may check for the current locale and set it according to the global setting in order to display the dialog correctly. Rhino has no need to check for locale changes and probably just moves on with the now “wrong” locale.

Two things you can check:
a) does the input work when you use , instead of . ?
b) install an english locale an make it current. (you can set language locale and keyboard layout independently to nit mess up your keyboard). Does the error still occur with english being the current global locale?

The TestToggle… command is a Rhino 5 command so this will not help for you.


#5

Hi HaLo,
I seems that it works. I changed the language to english from danish…
Thank you very much…
Best regards Jesper