Problem with Surface from network of curves

Hi!
I hope maybe you can help me, because i am loosing my hairs with this new problem! :grin:
I tried to make a closed polysurface, like i am using to do a lot of times, in order to send it for 3D printing in shapeways, or sculpteo.
I did those steps:

  • create a network of curves, and make it shure that those curves are good. I think this is ok
  • select those network of curves, and make surface wsith the command “Surface from network of curves”
  • make commande “offsetSRF”, in order to have a closed polysurface, in order i can print it in 3D
  • Convert this 3D file in STL file: and, i think that the problem comes from here, if the Rhino File i send it here is only 3 mo, the stl file more than 100 mo! When i export it in Sculpteo, the automatic reparing file of sculpteo makes me a very special shape, and a very complex object; and when i am trying to send the stl file in shapeways, they it is impossible to load, because the stl file is too big. It is the first time i have this problem, really, i don’t know what is wrong, can you please help me? :wink:
    I put the file in Rhino 5, i have the two licence commercial for Rhino 5 and 6, but i think, maybe, a lot of people are not yet in Rhino 6?
    Thanks so much
    Sandrine :grin:PourForumRhinoV5.3dm (2.3 MB)

Hello - this is what I get from V5 -
Kostaleak.stl (367.8 KB)
Does that look correct?

-Pascal

1 Like

Hello, yes, it is this, thanks a lot, but, as we see in the Rhino File, There is nothing to see with the shape i have in the Rhino File, and i don’t know why…? :thinking: :grinning:

Hm - I guess I do not understand what the problem is -

Do you see something different/

-Pascal

1 Like

you are working quite far from world origin ( about 30 kms away from zero). If I export your file as original. the stl size is 16MB. If I move the object to Zero, the stl size is 256KB
STL 30kms away:


STL in world origin:

4 Likes


Hi Pascal! Yes, the problem is that i see this, and it is nothing to do with what i designed!

Hi Diego!
Thanks so much!
I tried to put on the origin, and it is worst: my file has 7 mo, but when i open, there is nothing. The worst is that now, i can’t see the grid of Rhino, What is it happen with my Rhino? I tried to do in Rhino 6.
I put here a video that is the screenshot that all i have did:
https://vimeo.com/448117416
and i join you here the two files i have trying to put on the origin. I really don’t know what happens… :thinking: :grinning:PourSTLForumRhinoV5STL.stl (7.1 MB)

in your file after moving the object to Zero I reseted the 4 default views from the toolbar
image
everything looks fine here
maybe the mesh configuration you are using is too dense. I only use the default settings for that which works in most cases.

1 Like

Hi Diego, thanks so much. Do you have the same thing: it seems, when i select all, that i have two objects, very far each from each other. I don’t really know how to do to select only the object selected, and to delete the objects that are not selected, but what i did, i copy in another file the good object, and i exported this in stl, and now it seems ok. But, do you know how to do to delete in Rhino the objects that are not selected? Thanks so much! :grinning:

you can invert the selection with the _Invert command after selecting the object you want to keep.
you can add it as option to the context menu which apears when you click and hold right mouse button for a while:

image
image