Problem with submenu

unhandled

(Killian Picolo) #1

Hello everybody,

I have a small problem with the toolbars. When I left click on icon which has a sub-menu type line, cube, etc … that is to say, the vast majority of icons and this one systematically opens the submenu. In short it happens the same thing when I make a left click or a right click on an icon. Can someone please help me?

PS : I use Rhino 5, and I’m french sorry for my english.

Thanks in advance.


(Pascal Golay) #2

Hello - do you mean that no command runs, only the cascading toolbars?

But, if there is a command assigned to the top level button, which is the usual, then click-and-release on the button will run the command, and click-and -hold will cascade the toolbars. Does that make sense with what you are seeing?

-Pascal


(Killian Picolo) #3

Hello, thank you for your response.

Yes I understand what you mean. In fact no matter how I click, it always opens the cascade while in the tutorials that I made a left click throws the command of the main icon or me it opens the cascade and it is not very convenient. I do not have the possibility to directly launch the command of the main icon. For example if I want to make a cube, I click on the cube icon that opens the cascade so I click on the cube icon ( in the cascade menu) to finally click on the cube icon that starts the command.

Cordially. Killian.


(Pascal Golay) #4

Hi Killian - can you make sure that your toolbar buttons actually have commands at the top level button? (Shift-Right click on the button - you should see something like this:


not blank.

-Pascal


(Killian Picolo) #5

I actually watched, I have exactly the same thing as your picture

Thanks for your help Pascal.


(Pascal Golay) #6

Hi Killian - just as a test, do you have another mouse available to try?

-Pascal


(Killian Picolo) #7

I already tried to change the mouse. And then what I do not understand is on other software I do not have that kind of problem

Killian.


(Pascal Golay) #8

Hi KIllian - in Options > Toolbar, there is a setting for ‘Cascade delay’, perhaps that is set to zero or a very low number? (number is in milliseconds)

-Pascal


(Killian Picolo) #9

Already tried…
I think I have the same problem as this person : Rhino icon submenu
Maybe it’s a windows problem.

Thanks Pascal.


(Pascal Golay) #10

Hi Killian - what is the screen resolution on your display? And is Windows set to show the screen at 100% or some other scale?

-Pascal


(Killian Picolo) #11

I have a 27" 1920x1080. Windows display is 100%.
You think the problem could come from the screen?

Killian.


(Pascal Golay) #12

Hi Killian - no… that seems perfectly reasonable. I am at a loss…

@JohnM - do you have an idea? As I understand it, all of Killian’s cascading toolbar buttons at the top level only cascade and never run the command. As if the ‘hot’ triangle covers the whole button…

-Pascal


(Killian Picolo) #13

Never mind. Thank you very much for your help Pascal.

Killian.