Problem with Slicer (my model is more a husk than a fill model)

Hello everyone, I need some help, I make different models who are walls with an inside cord to join them, the problem is everytime i try to slice it i got problems; “not manifold or extraneous surface”, so i look some repair softwares, but my model get changed and I don’t want that.


I try modifying it as a continuos figure (join the walls and the cord) and i keep getting errors

This is what i get when i try to repair it; the model change the way i made it like this or it just ignore the cord.

I know the other way is to use grasshopper, but i don’t understand the logic way to get the gcode with the model using it, so if somebody has a software or a tip to repair it and get the gcode, it helps me a lot!. Thanks

The simplest solution would be to turn this into one simple solid then use the slicer settings to control wall thickness and infill, none of this hassle is necessary. Otherwise…we’d need to see the model to see what the problem is with it.

1 Like

If this is the final product, with the interior surface, then you will need to get creative with how you model it so that vase mode can be used.

Alternatively, you need to thicken all your surfaces and boolean union them so they become one solid, then use 0% in-fill.

There’s nothing to fix, it isn’t a broken STL file, you just haven’t modelled it properly.

image

2 Likes

You’re going to run into issues with slicers and open surfaces. At the very least define a thickness that’s the same as your extrusion width.

1 Like

Thank you so much, define thickness to the walls help me with the problem, i use the command “offsetsrf” and all was fixed, for my next projects i’ll design it thinking about that, i mean in this case, one side of the walls touch, but the other don’t, so next time i though about that, Thank you all for your comments!.