Problem with randomly moving cursor when using Rhino 6 on MSI laptop


I recently purchased a MSI WS66 10TKT-081 workstation for my job and have been encountering issues of mouse cursor randomly move and click around on the screen when using Rhino. It doesn’t happen when using browsers, Outlook, or other graphic intensive programs like Photoshop. So when I called MSI tech support they suggested this might be compatibility issue but not hardware or driver issue. Does anyone has the same issue when using Rhino on MSI workstation? Thank you!

Any chance you could post a video of what is happening? Have not seen this elsewhere.

Hi Kyle, the video I captured was somewhat less crazy…

wow… that is quite odd… I’m going to bounce this off our dev team and see if they have any ideas.

any chance you can grab video right from the screen using screen to gif or snagit? It’s a little hard to see what is happening and where the cursor is when it happens.

I tried to record it several times. But the one I captured has less movement and seemed to stop at the end. There are other occasions when the cursor just moves around like crazy. I tried three different mice and has same issue. They are all from Logitech tho. I tried both bluetooth and usb receiver mice.

Hello -

Please run the SystemInfo command in Rhino and copy/paste the results here.


Were you able to fix this issue? I have the same Laptop with the same issue on the other cad program I use (Not Rhino)

Which of these are you using:

  • a bluetooth external mouse
  • a usb external mouse
  • a wired external mouse
  • the trackpad
  • the touch screen?

Hi Jimmy Thanks for the replay, My laptop is a touch screen, but I am using an external Logitech M535 bluetooth mouse. Also tried to turn off the mouse and the touchpad neither help.

I’ve seen this before occasionally on laptops with multiple mouse/trackpad etc devices. Updating all the relevant drivers to the latest version and/or disabling all but one input device usually lead to a solution. If not, then if you can find one, try a wired mouse and turn off bluetooth.