Problem with pufferfish twisted boxer

Hello, i downloaded Pufferfish, but when i run it, i got some problems related to the twistedbox components like in the following images

Can some one help me?

As directions say. Close Rhino completely one time before using Pufferfish after the first install.

i did it 3 times, did not work

Not sure then, is there any other info for the errors? Is the gha unblocked? Do you happen to have COFF off? What version of Rhino 6 are you using? Where have you installed the gha?

I use Pufferfish on multiple computers for Rhino 5 and 6 and don’t get this errors. Can you click one of the errors and see what the additional information is?

I reseted my computer and now it works, Thak you for your help Michael.

1 Like

Who knows, glad it works. Guess sometimes you really do have to “turn if off then turn it back on again” haha


MIchael, i got a new problem, that i suspect i caused by my hardware, but anway. Using the box morph in the twisted box loft, my rhino crashed and i got the following message Sem%20t%C3%ADtulos
Do you know what can be causing this?
Thank you.

Not sure. If you can send me the file I can see what happens on my end, maybe there is an issue with geometry you are trying to morph. Or you can try on another computer and see if it also happens. For me the component works fine on multiple computers. I haven’t heard of that issue or got any other reports from other users about it. When does it crash? Is it when you input the twisted box loft into box morph? Or when you input a geometry into box morph?

In other computer it does work. The crash is when i input the twisted box loft into box morph.

Sounds like a problem with your hardware or rhino install if it works on another computer. What happens when you use twisted boxes from another source, like grasshoppers native surface box component?

Could it be related to Plankton missing?

Pufferfish does not use plankton or any other dependencies.

but can grasshopper crash because of this?

I atualized plankton and now it works. I Think the crash was in GH, but occured while using the pufferfish.