Problem with printing trimmed pictures

When I print a trimmed picture from the Model space with vector output selected, I get a mask overlaid on images that were trimmed with a circle or a curve. There are no issues with pictures that were trimmed using a rectangle.

If I print from Layouts view, the problem occurs not only in vector printing mode but also in raster.

I found the ticket RH-34639 seems to deal with this problem. But it is marked as Obsolete, even though the problem persists.

I also tested different image formats, but the issue seems to affect all of them.

Those look like mesh facet edges.
If you go into File > Settings > Mesh, tighten up the mesh settings with Smooth & slower, or a Custom setting that fits curves more accurately.

Does that improve the trim?

1 Like

Thank you, John. Unfortunately, changing mesh settings did not help. I am attaching the Rhino file and the jpeg used.

Untitled.3dm (3.3 MB)

I’m running 6.28
I just opened your file:

The issue is not with opening the file but printing it. Only raster output in model space prints well. Vector output in model space and both vector and raster outputs in layouts adds that white mask as it prints. Can you replicate this? A quick screen recording here: https://www.loom.com/share/fcbeb841326043578595fd516ceff9a7

Sorry, those specifics were not clear to me.
Checking now.

I see it now.
I’ll add a defect report.

https://mcneel.myjetbrains.com/youtrack/issue/RH-59787

Thank you, John, much appreciated.

RH-59787 is fixed in the latest Service Release Candidate