Problem with printer , only wireframes are printed

Hello,
I use rhino7 and when I want to print a page (on shaded mode for example) only wireframes are printed !
It is strange that Rhino cannot print what is displayed on a screen.
Is it because my intel graphic hd support only opengl 1.1 ?
Thanks.!

problem imprim rhino|690x431

Hi -

You have Vector Output selected, and that will only print the wires of surfaces. If you change that to Raster Output, you should get shaded surfaces.


-wim

But when I select Raster Output , all is black …

Hi -

Ha, that’s where this comes in, yes…

Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Education, build 2020-12-08
License details: Stand-Alone

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 7.9Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel® HD Graphics (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y). OpenGL Ver: 1.1.0
> Integrated graphics device with 2 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 11-4-2015
Driver Version: 15.201.1151.1008
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi -

This part shows that the drivers for your Intel GPU are not working.
I’d go to Downloads for Intel® HD Graphics Family to find current drivers and install those.
-wim

Thank you @wim but I have already the last version for intel hd 2000 (officially it is not work with windows 10) . I use mesa3d ( Mesa3D For Windows - Federico Dossena ) but it is not very good.

This is a screen capture :

This is now the SystemInfo :

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 7.9Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel® HD Graphics 3000 (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y). OpenGL Ver: 3.1 Mesa 20.1.8
> Integrated graphics device with 2 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: VMware, Inc.
Render version: 3.1
Shading Language: 1.40
Driver Date: NA
Driver Version: NA
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 2108 MB

Hi -

This first time that you posted the SystemInfo, it said:

Vendor Name: Microsoft Corporation

It appears that you are now running Rhino under virtualization (VMware), which is not supported.

When not running on VMware and after you update to the latest Rhino 7 version (7.6 or a 7.7 release candidate), you could try changing the OpenGL level that is used by moving the slider on the Rhino Options > View > OpenGL page to the left. Try moving one notch to the left at a time. You need to restart Rhino when you change this setting, then see if things improve. If not, move the slider another notch to the left and repeat the process.
-wim

And also an “unpaid” version…

image